summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorwoglinde <woglinde@ffa7fe5e-494d-0410-b361-a75ebd5db220>2011-07-30 21:13:19 +0000
committerwoglinde <woglinde@ffa7fe5e-494d-0410-b361-a75ebd5db220>2011-07-30 21:13:19 +0000
commit938e43c8d20da52b468abda52c25cbca523f5c60 (patch)
tree6a3dc75d1d7c77f38521d7f6606793f724795bc4 /configure.in
parent1ab379b9d989ee184379e24d9db09e1871adcc8d (diff)
downloadnavit-svn-938e43c8d20da52b468abda52c25cbca523f5c60.tar.gz
Fix:core: define HAVE_SYS_TIME_H for autotools too
git-svn-id: http://svn.code.sf.net/p/navit/code/trunk/navit@4665 ffa7fe5e-494d-0410-b361-a75ebd5db220
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index bddb0896..b773e9bb 100644
--- a/configure.in
+++ b/configure.in
@@ -345,6 +345,13 @@ AM_CONDITIONAL(EVENT_GLIB, [test "x$glib" = "xyes"])
AM_CONDITIONAL(SUPPORT_GLIB, [test "x$glib" = "xno"])
AM_CONDITIONAL(SUPPORT_EZXML, [test "x$glib" = "xno"])
+AC_CHECK_HEADER([sys/time.h],
+ [AC_DEFINE(
+ [HAVE_SYS_TIME_H],
+ [1],
+ [Define to 1 if you have the <sys/time.h> header file.])
+ ])
+
if test "x${ZLIB_CFLAGS}" = "x" -a "x${ZLIB_LIBS}" = "x"; then
AC_CHECK_HEADER(
zlib.h,