summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormartin-s <martin-s@ffa7fe5e-494d-0410-b361-a75ebd5db220>2011-07-21 09:18:51 +0000
committermartin-s <martin-s@ffa7fe5e-494d-0410-b361-a75ebd5db220>2011-07-21 09:18:51 +0000
commitb6a7548b812e652b196fff49dc89476aae0b7833 (patch)
tree995eacb8fbbac995316c468d75bd0e3272fbfed4 /configure.in
parent5f3b72704af26adba17f0c1ce09a176c6ec6c781 (diff)
downloadnavit-svn-b6a7548b812e652b196fff49dc89476aae0b7833.tar.gz
Fix:maptool:Better check for sbrk
git-svn-id: http://svn.code.sf.net/p/navit/code/trunk/navit@4656 ffa7fe5e-494d-0410-b361-a75ebd5db220
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 95ec21f3..bddb0896 100644
--- a/configure.in
+++ b/configure.in
@@ -388,6 +388,11 @@ AC_TRY_LINK([#include <stdlib.h>], [system("/bin/true");],AC_MSG_RESULT(yes);AC_
AC_MSG_CHECKING(for CreateProcess)
AC_TRY_LINK([#include <windows.h>], [CreateProcess(NULL,NULL,NULL,NULL,0,0,NULL,NULL,NULL,NULL);],AC_MSG_RESULT(yes);AC_DEFINE(HAVE_CREATEPROCESS, 1, [Define to 1 if you have the `CreateProcess' function.]) speech_cmdline=yes; speech_cmdline_reason="CreateProcess exists", AC_MSG_RESULT(no))
+# sbrk
+AC_MSG_CHECKING(for sbrk)
+AC_TRY_LINK([#include <unistd.h>], [sbrk(0);],AC_MSG_RESULT(yes);AC_DEFINE(HAVE_SBRK, 1, [Define to 1 if you have the `sbrk' function.]),AC_MSG_RESULT(no))
+
+
AC_ARG_ENABLE(graphics-sdl, [ --disable-graphics-sdl don't create graphics sdl], graphics_sdl=$enableval;graphics_sdl_reason="configure parameter")
if test "x${graphics_sdl}" = "xyes" ; then