summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormartin-s <martin-s@ffa7fe5e-494d-0410-b361-a75ebd5db220>2010-06-29 17:57:15 +0000
committermartin-s <martin-s@ffa7fe5e-494d-0410-b361-a75ebd5db220>2010-06-29 17:57:15 +0000
commitfad499b4879c6959f358a885f1fdbfd7ab2bdbaf (patch)
tree8cec2158a966b0efaea53d72f9ecc34b275f3a85 /configure.in
parent0c7003fd4970ce6306713a3151f5935bdc432b96 (diff)
downloadnavit-svn-fad499b4879c6959f358a885f1fdbfd7ab2bdbaf.tar.gz
Fix:Build:Better xgettext glade support check
git-svn-id: http://svn.code.sf.net/p/navit/code/trunk/navit@3449 ffa7fe5e-494d-0410-b361-a75ebd5db220
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 9b6414a9..f9d73427 100644
--- a/configure.in
+++ b/configure.in
@@ -691,6 +691,7 @@ POFILES=""
POIFILES=""
LINGUAS=""
+xgettext_glade=no
if test "x$enable_nls" = "xyes"; then
AC_CHECK_FUNC(gettext, [HAVEGETTEXT="yes"],[INTLIBS="-lintl" HAVEGETTEXT="yes"])
@@ -703,7 +704,9 @@ if test "x$enable_nls" = "xyes"; then
echo "xgettext isn't GNU version"
XGETTEXT=""
else
- AM_CONDITIONAL(XGETTEXT_GLADE, $XGETTEXT --help 2>&1 | grep Glade >/dev/null)
+ if $XGETTEXT --help 2>&1 | grep Glade >/dev/null; then
+ xgettext_glade=yes
+ fi
fi
fi
@@ -753,6 +756,7 @@ fi
fi
AM_CONDITIONAL(ENABLE_NLS, [test "x$enable_nls" = "xyes"])
+AM_CONDITIONAL(XGETTEXT_GLADE, [test "x$xgettext_glade" = "xyes"])
AC_CHECK_HEADER(
byteswap.h,
AC_DEFINE(