summaryrefslogtreecommitdiff
path: root/navit/CMakeLists.txt
diff options
context:
space:
mode:
authormartin-s <martin-s@ffa7fe5e-494d-0410-b361-a75ebd5db220>2011-05-09 12:49:34 +0000
committermartin-s <martin-s@ffa7fe5e-494d-0410-b361-a75ebd5db220>2011-05-09 12:49:34 +0000
commit19c27d647a407b80f53b85e394c357595b1ae56e (patch)
tree9b08da0d0eddf570dad09cc654d2270e6049a899 /navit/CMakeLists.txt
parenta3f74044f87c7d55d2ee849787c58677aea3eebf (diff)
downloadnavit-svn-19c27d647a407b80f53b85e394c357595b1ae56e.tar.gz
Add:Build:Option to disable win32 resources
git-svn-id: http://svn.code.sf.net/p/navit/code/trunk/navit@4487 ffa7fe5e-494d-0410-b361-a75ebd5db220
Diffstat (limited to 'navit/CMakeLists.txt')
-rw-r--r--navit/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/navit/CMakeLists.txt b/navit/CMakeLists.txt
index 44ef7ee5..31c53723 100644
--- a/navit/CMakeLists.txt
+++ b/navit/CMakeLists.txt
@@ -66,8 +66,11 @@ endforeach()
add_subdirectory (fib-1.1)
if(NOT ANDROID)
- # add_executable (navit start.c ${CMAKE_CURRENT_SOURCE_DIR}/gui/win32/resources/resource.rc)
- add_executable (navit start.c)
+ if(WIN32 OR WINCE AND NOT WIN_OMIT_RESOURCES)
+ add_executable (navit start.c ${CMAKE_CURRENT_SOURCE_DIR}/gui/win32/resources/resource.rc)
+ else()
+ add_executable (navit start.c)
+ endif()
target_link_libraries (navit ${NAVIT_LIBNAME})
set_target_properties(navit PROPERTIES COMPILE_DEFINITIONS "MODULE=${MODULE_NAME}")