summaryrefslogtreecommitdiff
path: root/navit/maptool/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'navit/maptool/CMakeLists.txt')
-rw-r--r--navit/maptool/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/navit/maptool/CMakeLists.txt b/navit/maptool/CMakeLists.txt
index 848e2c10..48e8c3f1 100644
--- a/navit/maptool/CMakeLists.txt
+++ b/navit/maptool/CMakeLists.txt
@@ -1,7 +1,9 @@
if(BUILD_MAPTOOL)
add_definitions( -DMODULE=maptool )
- add_library (maptool_core boundaries.c buffer.c ch.c coastline.c geom.c itembin.c itembin_buffer.c misc.c osm.c sourcesink.c tempfile.c tile.c zip.c )
+ include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+ add_library (maptool_core boundaries.c buffer.c ch.c coastline.c geom.c itembin.c itembin_buffer.c misc.c osm.c sourcesink.c tempfile.c tile.c zip.c
+ osm_protobuf.c generated-code/fileformat.pb-c.c generated-code/osmformat.pb-c.c google/protobuf-c/protobuf-c.c)
add_executable (maptool maptool.c)
target_link_libraries(maptool maptool_core navit_core ${NAVIT_LIBS} m)