summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Wildemann <metalstrolch@users.noreply.github.com>2017-05-05 05:04:00 +0200
committerPierre GRANDIN <pgrandin@users.noreply.github.com>2017-05-04 20:04:00 -0700
commit585305d57ce8e1c5a3db978086102604f55cb006 (patch)
tree729b8e85769c9122f0a84e241d369373408e744a /CMakeLists.txt
parenta5b607303d83e2b46950e2aef63eb5787f3098fb (diff)
downloadnavit-585305d57ce8e1c5a3db978086102604f55cb006.tar.gz
Add Qt5 qml gui skeleton (#236)R7461
* Initial parts of qt5 qml graphics based on graphics/qt5_qml * Qt5 QML gui: working handover The hand over of the QML engine between the graphics and the gui part is working now. The gui can load it's own QML component and embed the navit widget inside other QML code. * Remove unneeded moc include * Fix: Apply coding style * Fix:extern "C" the navit includes in graphics qt5 Seems the navit includes are not fully "c++" aware, so extern "C" them in the c++ parts.
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e4e5ed7aa..8804c0184 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -96,6 +96,7 @@ add_module(graphics/egl "Required library not found" FALSE)
add_module(graphics/qt_qpainter "Qt libraries not found" FALSE)
add_module(graphics/qt5 "Qt5 libraries not found" FALSE)
add_module(gui/qml "Qt Declarative not found" FALSE)
+add_module(gui/qt5_qml "Qt5 Declarative not found" FALSE)
add_module(gui/gtk "GTK libs not found" FALSE)
add_module(vehicle/gpsd "gpsd lib not found" FALSE)
add_module(vehicle/gypsy "gypsy lib not found" FALSE)
@@ -339,6 +340,9 @@ if (Qt5Widgets_FOUND OR Qt5Quick_FOUND)
if(USE_QML)
set(Qt5_ADDITIONAL_LIBRARIES ${Qt5_ADDITIONAL_LIBRARIES} ${Qt5Quick_LIBRARIES})
endif()
+ set_with_reason(gui/qt5_qml "Qt5 found" TRUE
+ ${Qt5Quick_LIBRARIES})
+
endif()
set_with_reason(graphics/qt5 "Qt5 found" TRUE
${Qt5_ADDITIONAL_LIBRARIES}