summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormvglasow <michael -at- vonglasow.com>2018-05-09 15:14:01 +0200
committermvglasow <michael -at- vonglasow.com>2018-05-09 15:14:01 +0200
commitf661c8f3f259ed10b6e79477d8125a1f7350d2a2 (patch)
tree4d9b61190f52f031fd70ce7d74fe2b666d38e1bd /CMakeLists.txt
parent2a452615f75c028964b234135959695180e82d65 (diff)
parent03f3aa8637fff3e8e09d3bde21b28654454011fd (diff)
downloadnavit-f661c8f3f259ed10b6e79477d8125a1f7350d2a2.tar.gz
Merge branch 'trunk' into traffic
# Conflicts: # navit/route.c # navit/xmlconfig.c
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt41
1 files changed, 25 insertions, 16 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7d0d19a17..18a0992c2 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -684,25 +684,34 @@ if (HAS_IFADDRS)
endif(HAS_IFADDRS)
if(ANDROID)
- find_program(ANDROID_LOCATION NAMES android android.bat)
- find_program(ANT_LOCATION NAMES ant)
- if (NOT ANT_LOCATION)
- message_error("Could not find ant. Please install ant and add it to the search path.")
- else()
- execute_process(COMMAND ${ANT_LOCATION} WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/cmake RESULT_VARIABLE ANT_VERSION_OK OUTPUT_QUIET ERROR_QUIET)
- if(ANT_VERSION_OK GREATER 0)
- message(WARNING "Old ant version detected. If you need crash reporter, update to at least ant 1.8")
+ message(STATUS "Using generator "${CMAKE_GENERATOR})
+ if (NOT ${CMAKE_GENERATOR} STREQUAL Ninja)
+ find_program(ANDROID_LOCATION NAMES android android.bat)
+ find_program(ANT_LOCATION NAMES ant)
+ if (NOT ANT_LOCATION)
+ message_error("Could not find ant. Please install ant and add it to the search path.")
+ else()
+ execute_process(COMMAND ${ANT_LOCATION} WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/cmake RESULT_VARIABLE ANT_VERSION_OK OUTPUT_QUIET ERROR_QUIET)
+ if(ANT_VERSION_OK GREATER 0)
+ message(WARNING "Old ant version detected. If you need crash reporter, update to at least ant 1.8")
+ endif()
endif()
- endif()
- if (NOT ANDROID_LOCATION)
- message_error( "Could not find 'Android SDK and AVD Manager'. Please install the android sdk and add the <android-sdk>/tools directory to the search path.")
- endif()
- set(XSLTS "android;${XSLTS}" CACHE STRING "define a semicolon seperated list of XSLTs to process")
+ if (NOT ANDROID_LOCATION)
+ message_error( "Could not find 'Android SDK and AVD Manager'. Please install the android sdk and add the <android-sdk>/tools directory to the search path.")
+ endif()
+ set(XSLTS "android;${XSLTS}" CACHE STRING "define a semicolon seperated list of XSLTs to process")
+ endif (NOT ${CMAKE_GENERATOR} STREQUAL Ninja)
list(APPEND NAVIT_LIBS log)
set(HAVE_API_ANDROID 1)
- set_with_reason(graphics/android "Android detected, NDK:${ANDROID_NDK_API_VERSION}, API:${ANDROID_API_VERSION}" TRUE)
- set_with_reason(speech/android "Android detected, NDK:${ANDROID_NDK_API_VERSION}, API:${ANDROID_API_VERSION}" TRUE)
- set_with_reason(vehicle/android "Android detected, NDK:${ANDROID_NDK_API_VERSION}, API:${ANDROID_API_VERSION}" TRUE)
+ set_with_reason(speech/cmdline "Android detected" FALSE)
+ set_with_reason(graphics/null "Android detected" FALSE)
+ set_with_reason(graphics/android "Android detected" TRUE)
+ set_with_reason(speech/android "Android detected" TRUE)
+ set_with_reason(vehicle/android "Android detected" TRUE)
+ set_with_reason(vehicle/file "Android detected" FALSE)
+ set_with_reason(map/filter "Android detected" FALSE)
+ set_with_reason(USE_NATIVE_LANGUAGE_SUPPORT "Android detected" TRUE)
+# set_with_reason(plugin/pedestrian "Android detected" TRUE)
set(SHARED_LIBNAVIT TRUE)
add_feature(XPM2PNG "Android detected" TRUE)