summaryrefslogtreecommitdiff
path: root/navit/CMakeLists.txt
diff options
context:
space:
mode:
authorjkoan <jkoan@users.noreply.github.com>2020-01-19 00:07:23 +0100
committerPierre GRANDIN <pgrandin@users.noreply.github.com>2020-01-18 16:07:23 -0700
commit37715fe8301c6ebbc5e85c6f370dd7afd16f5792 (patch)
tree90931ca1b96c0aa7fafe14cc5b5ecbb79e613d44 /navit/CMakeLists.txt
parentdf8c2e319193ac3c7f8dda4082937b542e1f3a92 (diff)
downloadnavit-37715fe8301c6ebbc5e85c6f370dd7afd16f5792.tar.gz
Fix run when in build dir (#957)
* add:build:core:Add file which is only visible to devs to detect when navit is running in build dir
Diffstat (limited to 'navit/CMakeLists.txt')
-rw-r--r--navit/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/navit/CMakeLists.txt b/navit/CMakeLists.txt
index 1234bd0cb..5f7ee3cd7 100644
--- a/navit/CMakeLists.txt
+++ b/navit/CMakeLists.txt
@@ -3,6 +3,8 @@ include_directories( "${PROJECT_SOURCE_DIR}")
include_directories( "${CMAKE_CURRENT_SOURCE_DIR}")
include_directories( "${CMAKE_CURRENT_BINARY_DIR}")
include_directories( "${CMAKE_CURRENT_SOURCE_DIR}/support")
+file(WRITE ${CMAKE_CURRENT_BINARY_DIR}/THIS_IS_THE_NAVIT_WORKING_DIR "\r\nThis File should never appear on binary distributions\r\n" )
+file(WRITE ${CMAKE_CURRENT_BINARY_DIR}/THIS_IS_THE_NAVIT_WORKING_DIR "\r\nOnly Devs should ever see this file" )
# navit core
set(NAVIT_SRC announcement.c atom.c attr.c cache.c callback.c command.c config_.c coord.c country.c data_window.c debug.c