summaryrefslogtreecommitdiff
path: root/navit/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastian Leske <sebastian.leske@sleske.name>2015-08-28 08:14:22 +0200
committerSebastian Leske <sebastian.leske@sleske.name>2015-08-30 00:56:39 +0200
commit425f2b01a68159d084e6cfa4b8cae39b4fb56a28 (patch)
tree8607b03b6f421d0741b955cd6c11f16554f972d3 /navit/CMakeLists.txt
parentdd6b8208c88c0dbcccf3c8d5ea7d6fe159f674c8 (diff)
downloadnavit-425f2b01a68159d084e6cfa4b8cae39b4fb56a28.tar.gz
Fix:build:Detect current git version, remove Subversion checks. We don't do Subversion anymore...
Diffstat (limited to 'navit/CMakeLists.txt')
-rw-r--r--navit/CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/navit/CMakeLists.txt b/navit/CMakeLists.txt
index d0d57e230..daf8abe8d 100644
--- a/navit/CMakeLists.txt
+++ b/navit/CMakeLists.txt
@@ -107,12 +107,11 @@ if (DEFINED NAVIT_COMPILE_FLAGS)
set_target_properties(${NAVIT_LIBNAME} PROPERTIES COMPILE_FLAGS "${NAVIT_COMPILE_FLAGS}")
endif()
-# Subversion revision
ADD_CUSTOM_TARGET(
- version
+ git_version
${CMAKE_COMMAND} -D SRC=${CMAKE_CURRENT_SOURCE_DIR}/version.h.in
-D DST=${CMAKE_CURRENT_BINARY_DIR}/version.h
- -D NAME=SVN_VERSION
+ -D NAME="GIT_VERSION"
-P ${PROJECT_SOURCE_DIR}/cmake/version.cmake
)
@@ -153,7 +152,7 @@ else()
add_custom_target( navit_config_xml ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/navit.xml)
endif()
-ADD_DEPENDENCIES(${NAVIT_LIBNAME} version)
+ADD_DEPENDENCIES(${NAVIT_LIBNAME} git_version)
if (USE_LIBGNUINTL AND NOT HAVE_GLIB)
ADD_DEPENDENCIES(support_glib support_gettext_intl)
endif()