summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cf942edf6..d354383ce 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -603,6 +603,10 @@ if (APPLE OR USE_UIKIT)
set(BUILD_BUNDLE TRUE CACHE BOOLEAN "build an osx bundle")
endif()
+if(CMAKE_SIZEOF_VOID_P LESS 8)
+ set_with_reason(BUILD_MAPTOOL "maptool works only on 64 bit architectures" FALSE)
+endif()
+
set(LOCALEDIR "${LOCALE_DIR}/locale")
find_program(BZCAT NAMES bzcat)
@@ -613,6 +617,9 @@ if (SAMPLE_MAP)
elseif(NOT BZCAT)
cfg_feature(SAMPLE_MAP "downloading binary map because of missing bzcat" TRUE)
set(DOWNLOAD_SAMPLE_MAP TRUE)
+ elseif(NOT BUILD_MAPTOOL)
+ cfg_feature(SAMPLE_MAP "downloading binary map because maptool compilation is disabled" TRUE)
+ set(DOWNLOAD_SAMPLE_MAP TRUE)
endif(CMAKE_CROSSCOMPILING)
endif(SAMPLE_MAP)