summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3e6d4c683..a03cdc835 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -687,6 +687,13 @@ if(CMAKE_SIZEOF_VOID_P LESS 8)
set_with_reason(BUILD_MAPTOOL "maptool works only on 64 bit architectures" FALSE)
endif()
+if(BUILD_MAPTOOL)
+ find_package(Protobuf-c REQUIRED)
+ if(NOT PROTOBUF_C_FOUND)
+ set_with_reason(BUILD_MAPTOOL "PROTOBUF-C not found" FALSE)
+ endif()
+endif()
+
set(LOCALEDIR "${LOCALE_DIR}")
find_program(BZCAT NAMES bzcat)