summaryrefslogtreecommitdiff
path: root/contrib/sailfish/navit-sailfish.spec
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/sailfish/navit-sailfish.spec')
-rwxr-xr-xcontrib/sailfish/navit-sailfish.spec50
1 files changed, 43 insertions, 7 deletions
diff --git a/contrib/sailfish/navit-sailfish.spec b/contrib/sailfish/navit-sailfish.spec
index a798aa487..4f14be872 100755
--- a/contrib/sailfish/navit-sailfish.spec
+++ b/contrib/sailfish/navit-sailfish.spec
@@ -9,13 +9,15 @@
Name: harbour-navit
Summary: Open Source car navigation system
#Version: %{navit_version}_%{git_version}
-Version: 0.5.1
-Release: 4
+Version: 0.5.3
+Release: 1
License: GPL
Group: Applications/Productivity
-URL: http://navit-projet.org/
+URL: http://navit-project.org/
-BuildRequires: gcc
+#git is vor version info while building
+BuildRequires: git
+#BuildRequires: gcc
BuildRequires: cmake
BuildRequires: glib2-devel
BuildRequires: gettext-devel
@@ -73,7 +75,7 @@ mkdir navit-build
%build
%define debug_package %{nil}
%{__rm} -rf %{buildroot}
-#cmake git files directly
+#cmake git files directly
cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr \
-DPACKAGE:STRING=harbour-navit \
-DNAVIT_BINARY:STRING=harbour-navit \
@@ -97,7 +99,12 @@ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr \
%{navit_real_source}
%{__make}
-# -DMAN_DIR:PATH=share/harbour-navit/man1
+# -DMAN_DIR:PATH=share/harbour-navit/man1
+
+%pre
+if [ -d %{_datadir}/harbour-navit/espeak-data ]; then
+ rm -rf %{_datadir}/harbour-navit/espeak-data
+fi
%install
%make_install
@@ -107,6 +114,12 @@ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr \
%files
%defattr(644, root, root, 755)
%{_datadir}/harbour-navit/navit.xml
+%{_datadir}/harbour-navit/navit_layout_bike.xml
+%{_datadir}/harbour-navit/navit_layout_car.xml
+%{_datadir}/harbour-navit/navit_layout_car_android.xml
+%{_datadir}/harbour-navit/navit_layout_car_dark.xml
+%{_datadir}/harbour-navit/navit_layout_car_simple.xml
+%{_datadir}/harbour-navit/navit_layout_th.xml
%{_datadir}/harbour-navit/icons/
%{_datadir}/harbour-navit/maps/osm_bbox_11.3,47.9,11.7,48.2.bin
%{_datadir}/harbour-navit/espeak-data/
@@ -123,6 +136,29 @@ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr \
%changelog
+*Mon Oct 01 2018 metalstrolch 0.5.3-1
+- fix rpm updating from 0.5.1 by adding %pre section
+
+*Fri Aug 31 2018 metalstrolch 0.5.3-0
+
+Release 0.5.2 was missing the version number update in the CMakefile. This release fixes this.
+
+*Fri Aug 31 2018 metalstrolch 0.5.2-0
+
+This release has seen a big work on code quality and homogeneity.
+
+If you want to know what has changed see the Changelog at: https://github.com/navit-gps/navit/blob/v0.5.2/CHANGELOG.md
+
+For the full list of commits, see: v0.5.1...v0.5.2
+
+Please report issues at http://trac.navit-project.org or https://github.com/navit-gps/navit/issues
+The documentation can be found at http://navit.readthedocs.io/
+
+To get the latest builds, see: http://download.navit-project.org/
+
+*Tue Oct 17 2017 metalstrolch 0.5.1-5
+- Update upstream
+
*Tue Oct 17 2017 metalstrolch 0.5.1-4
- Fix medium GUI icon size to cope with changed icon set on upstream
- Update upstream
@@ -139,7 +175,7 @@ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr \
*Mon Apr 10 2017 metalstrolch 0.5.1-1
- Almost harbour valid
-*Mon Dec 14 2015 metalstrolch 0.5.1-0
+*Mon Dec 14 2015 metalstrolch 0.5.1-0
- Initial sailfish release
- Initial package.