summaryrefslogtreecommitdiff
path: root/navit/graphics/qt5/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'navit/graphics/qt5/CMakeLists.txt')
-rw-r--r--navit/graphics/qt5/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/navit/graphics/qt5/CMakeLists.txt b/navit/graphics/qt5/CMakeLists.txt
index 9ecd7171e..d162f29a0 100644
--- a/navit/graphics/qt5/CMakeLists.txt
+++ b/navit/graphics/qt5/CMakeLists.txt
@@ -13,6 +13,8 @@ set(QML 0)
set(QWIDGET 0)
set(HAVE_FREETYPE 0)
+set(MODULE_BUILD_TYPE SHARED)
+
# check if we have FREETYPE
if(font/freetype)
set(HAVE_FREETYPE 1)
@@ -31,6 +33,9 @@ if(USE_QWIDGET)
set(GRAPHICS_QT5_ADDITIONAL ${GRAPHICS_QT5_ADDITIONAL} "QNavitWidget.cpp")
endif ()
-module_add_library(graphics_qt5 graphics_qt5.cpp event_qt5.cpp navitinstance.h ${GRAPHICS_QT5_ADDITIONAL})
+module_add_library(graphics_qt5 graphics_qt5.cpp event_qt5.cpp navithelper.cpp navitinstance.h ${GRAPHICS_QT5_ADDITIONAL})
+
# pass QML and QWIDGET preference to source
target_compile_definitions(graphics_qt5 PRIVATE USE_QML=${QML} USE_QWIDGET=${QWIDGET} HAVE_FREETYPE=${HAVE_FREETYPE})
+
+