summaryrefslogtreecommitdiff
path: root/navit/maps/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'navit/maps/CMakeLists.txt')
-rw-r--r--navit/maps/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/navit/maps/CMakeLists.txt b/navit/maps/CMakeLists.txt
index 3bd7a8f44..dbda66e2e 100644
--- a/navit/maps/CMakeLists.txt
+++ b/navit/maps/CMakeLists.txt
@@ -2,7 +2,6 @@ if(SAMPLE_MAP)
set(SAMPLE_MAP_NAME osm_bbox_11.3,47.9,11.7,48.2)
set(maptool_args "--attr-debug-level=5")
- GET_TARGET_PROPERTY(MAPTOOL_PATH maptool LOCATION)
add_custom_target(sample_map ALL DEPENDS ${SAMPLE_MAP_NAME}.xml)
add_custom_command (
OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/${SAMPLE_MAP_NAME}.xml
@@ -25,7 +24,7 @@ if(SAMPLE_MAP)
add_custom_command (
OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/${SAMPLE_MAP_NAME}.bin
COMMAND bzcat ${CMAKE_CURRENT_BINARY_DIR}/${SAMPLE_MAP_NAME}.osm.bz2
- | ${MAPTOOL_PATH} ${maptool_args} ${CMAKE_CURRENT_BINARY_DIR}/${SAMPLE_MAP_NAME}.bin
+ | $<TARGET_FILE:maptool> ${maptool_args} ${CMAKE_CURRENT_BINARY_DIR}/${SAMPLE_MAP_NAME}.bin
VERBATIM
DEPENDS maptool ${CMAKE_CURRENT_BINARY_DIR}/${SAMPLE_MAP_NAME}.osm.bz2
)