summaryrefslogtreecommitdiff
path: root/navit/xpm/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'navit/xpm/CMakeLists.txt')
-rw-r--r--navit/xpm/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/navit/xpm/CMakeLists.txt b/navit/xpm/CMakeLists.txt
index 096d76ff0..c9153839a 100644
--- a/navit/xpm/CMakeLists.txt
+++ b/navit/xpm/CMakeLists.txt
@@ -66,8 +66,8 @@ macro(add_scale_targets IMAGE_SRC IMAGE_NAME)
endforeach()
endmacro()
-if(NOT DEFINED ${NAVIT_BINARY})
- set(NAVIT_BINARY navit)
+if(NOT DEFINED NAVIT_BINARY)
+ set(NAVIT_BINARY navit CACHE STRING "Navit binary name not defined")
endif()
#patch binary name in desktop file
configure_file(desktop_icons/navit.desktop.in desktop_icons/${PACKAGE}.desktop)