summaryrefslogtreecommitdiff
path: root/navit/xpm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'navit/xpm/Makefile.am')
-rw-r--r--navit/xpm/Makefile.am341
1 files changed, 0 insertions, 341 deletions
diff --git a/navit/xpm/Makefile.am b/navit/xpm/Makefile.am
deleted file mode 100644
index 40b7cc851..000000000
--- a/navit/xpm/Makefile.am
+++ /dev/null
@@ -1,341 +0,0 @@
-include $(top_srcdir)/Makefile.inc
-
-image_DATA = cemetery.xpm
-image_DATA += dumping_station.xpm
-image_DATA += highway_exit.xpm
-image_DATA += hunting_stand.xpm
-image_DATA += level_crossing.xpm
-image_DATA += tower.xpm
-image_DATA += trailerpark.xpm
-image_DATA += public_office.xpm
-
-
-## Obsolete. Should be removed eventually...
-
-image_DATA += biergarten.xpm
-image_DATA += bus_halt.xpm
-image_DATA += car_dealer.xpm
-image_DATA += castle.xpm
-image_DATA += library.xpm
-image_DATA += memorial.xpm
-image_DATA += picnic.xpm
-image_DATA += potable_water.xpm
-image_DATA += restroom.xpm
-image_DATA += sport.xpm
-image_DATA += menu.xpm
-image_DATA += toggle_fullscreen.xpm
-
-## Obsolete end
-
-
-image_DATA += flag_bk_tr.xpm
-image_DATA += flag_bk_wh.xpm
-image_DATA += flag_bl_wh.xpm
-image_DATA += flag_wh_bk.xpm
-
-image_DATA += gc_tradi.xpm
-image_DATA += gc_multi.xpm
-image_DATA += gc_mystery.xpm
-image_DATA += gc_event.xpm
-image_DATA += gc_reference.xpm
-image_DATA += gc_webcam.xpm
-image_DATA += gc_question.xpm
-image_DATA += gc_stages.xpm
-
-image_DATA += nav_left_1.xpm
-image_DATA += nav_left_2.xpm
-image_DATA += nav_right_1.xpm
-image_DATA += nav_right_2.xpm
-image_DATA += nav_straight.xpm
-image_DATA += nav_straight_32.xpm
-image_DATA += nav_left_1_32.xpm
-image_DATA += nav_left_2_32.xpm
-image_DATA += nav_right_1_32.xpm
-image_DATA += nav_right_2_32.xpm
-
-svgs = gui_about.svg
-svgs += gui_actions.svg
-svgs += gui_active.svg
-svgs += gui_android_menu.svg
-svgs += gui_bookmark.svg
-svgs += gui_formerdests.svg
-svgs += gui_display.svg
-svgs += gui_help.svg
-svgs += gui_home.svg
-svgs += gui_inactive.svg
-svgs += gui_map.svg
-svgs += gui_maps.svg
-svgs += gui_rules.svg
-svgs += gui_settings.svg
-svgs += gui_sound.svg
-svgs += gui_sound_off.svg
-svgs += gui_tools.svg
-svgs += gui_fullscreen.svg
-svgs += gui_leave_fullscreen.svg
-svgs += gui_quit.svg
-svgs += gui_stop.svg
-svgs += gui_town.svg
-svgs += gui_vehicle.svg
-svgs += gui_vehicle_pedestrian.svg
-svgs += gui_zoom_in.svg
-svgs += gui_zoom_out.svg
-svgs += zoom_in.svg
-svgs += zoom_out.svg
-svgs += gui_select_street.svg
-svgs += gui_select_town.svg
-svgs += gui_select_country.svg
-svgs += gui_arrow_left.svg
-svgs += gui_arrow_right.svg
-svgs += gui_arrow_up.svg
-svgs += gui_arrow_down.svg
-svgs += gui_menu.svg
-svgs += gui_strength_0.svg
-svgs += gui_strength_1.svg
-svgs += gui_strength_2.svg
-svgs += gui_strength_3.svg
-svgs += gui_strength_4.svg
-svgs += gui_strength_5.svg
-svgs += gui_minus.svg
-svgs += gui_plus.svg
-svgs += gui_log.svg
-svgs += gui_search.svg
-svgs += menu.svg
-svgs += toggle_fullscreen.svg
-
-svgs += airport.svg
-svgs += atm.svg
-svgs += attraction.svg
-svgs += bahai.svg
-svgs += bank.svg
-svgs += bar.svg
-svgs += beer.svg
-svgs += bench.svg
-svgs += bicycle_parking.svg
-svgs += bicycle_rental.svg
-svgs += bicycle_shop.svg
-svgs += biergarten.svg
-svgs += boat_ramp.svg
-svgs += boundary_stone.svg
-svgs += buddhist.svg
-svgs += bus.svg
-svgs += bus_stop.svg
-svgs += cafe.svg
-svgs += camping.svg
-svgs += car_dealer.svg
-svgs += car_rent.svg
-svgs += car_sharing.svg
-svgs += casino.svg
-svgs += castle.svg
-svgs += church.svg
-svgs += cinema.svg
-svgs += cursor.svg
-svgs += cursor225.svg
-svgs += cursor450.svg
-svgs += cursor675.svg
-svgs += cursor_still.svg
-svgs += dam.svg
-svgs += danger.svg
-svgs += daymark.svg
-svgs += drinking_water.svg
-svgs += emergency.svg
-svgs += exit.svg
-svgs += fastfood.svg
-svgs += firebrigade.svg
-svgs += fountain.svg
-svgs += fuel.svg
-svgs += golf.svg
-svgs += heliport.svg
-svgs += hindu.svg
-svgs += hospital.svg
-svgs += hotel.svg
-svgs += information.svg
-svgs += islamic.svg
-svgs += jain.svg
-svgs += jewish.svg
-svgs += justice.svg
-svgs += library.svg
-svgs += mark.svg
-svgs += memorial.svg
-svgs += menu.svg
-svgs += military.svg
-svgs += mini_roundabout.svg
-svgs += museum.svg
-svgs += pagan.svg
-svgs += parking.svg
-svgs += pastafarian.svg
-svgs += peak.svg
-svgs += pharmacy.svg
-svgs += picnic.svg
-svgs += police.svg
-svgs += post.svg
-svgs += rail_station.svg
-svgs += repair_service.svg
-svgs += resort.svg
-svgs += restaurant.svg
-svgs += ruins.svg
-svgs += school.svg
-svgs += shelter.svg
-svgs += shinto.svg
-svgs += shop_apparel.svg
-svgs += shop_computer.svg
-svgs += shop_department.svg
-svgs += shop_grocery.svg
-svgs += shopping.svg
-svgs += sikh.svg
-svgs += skiing.svg
-svgs += sport.svg
-svgs += stadium.svg
-svgs += status_calculating_bk.svg
-svgs += status_calculating_wh.svg
-svgs += status_no_destination_bk.svg
-svgs += status_no_destination_wh.svg
-svgs += status_no_route_bk.svg
-svgs += status_no_route_wh.svg
-svgs += status_position_wait_bk.svg
-svgs += status_position_wait_wh.svg
-svgs += status_recalculating_bk.svg
-svgs += status_recalculating_wh.svg
-svgs += status_routing_bk.svg
-svgs += status_routing_wh.svg
-svgs += swimming.svg
-svgs += taoist.svg
-svgs += taxi.svg
-svgs += tec_common.svg
-svgs += telephone.svg
-svgs += theater.svg
-svgs += toggle_fullscreen.svg
-svgs += toilets.svg
-svgs += townhall.svg
-svgs += traffic_signals.svg
-svgs += unknown.svg
-svgs += viewpoint.svg
-svgs += wifi.svg
-svgs += worship.svg
-svgs += zoo.svg
-svgs += zoom_in.svg
-svgs += zoom_out.svg
-
-
-nav_svgs = nav_left_1_bk.svg nav_left_1_wh.svg nav_left_2_bk.svg nav_left_2_wh.svg nav_left_3_bk.svg nav_left_3_wh.svg
-nav_svgs += nav_right_1_bk.svg nav_right_1_wh.svg nav_right_2_bk.svg nav_right_2_wh.svg nav_right_3_bk.svg nav_right_3_wh.svg
-nav_svgs += nav_roundabout_l1_bk.svg nav_roundabout_l1_wh.svg nav_roundabout_l2_bk.svg nav_roundabout_l2_wh.svg
-nav_svgs += nav_roundabout_l3_bk.svg nav_roundabout_l3_wh.svg nav_roundabout_l4_bk.svg nav_roundabout_l4_wh.svg
-nav_svgs += nav_roundabout_l5_bk.svg nav_roundabout_l5_wh.svg nav_roundabout_l6_bk.svg nav_roundabout_l6_wh.svg
-nav_svgs += nav_roundabout_l7_bk.svg nav_roundabout_l7_wh.svg nav_roundabout_l8_bk.svg nav_roundabout_l8_wh.svg
-nav_svgs += nav_roundabout_r1_bk.svg nav_roundabout_r1_wh.svg nav_roundabout_r2_bk.svg nav_roundabout_r2_wh.svg
-nav_svgs += nav_roundabout_r3_bk.svg nav_roundabout_r3_wh.svg nav_roundabout_r4_bk.svg nav_roundabout_r4_wh.svg
-nav_svgs += nav_roundabout_r5_bk.svg nav_roundabout_r5_wh.svg nav_roundabout_r6_bk.svg nav_roundabout_r6_wh.svg
-nav_svgs += nav_roundabout_r7_bk.svg nav_roundabout_r7_wh.svg nav_roundabout_r8_bk.svg nav_roundabout_r8_wh.svg
-nav_svgs += nav_straight_bk.svg nav_straight_wh.svg nav_turnaround_left_bk.svg nav_turnaround_left_wh.svg
-nav_svgs += nav_turnaround_right_bk.svg nav_turnaround_right_wh.svg nav_destination_bk.svg nav_destination_wh.svg
-
-flag_svgs = country_.svgz country_AD.svgz country_AE.svgz country_AF.svgz country_AG.svgz country_AI.svgz country_AL.svgz country_AM.svgz
-flag_svgs += country_AN.svgz country_AO.svgz country_AQ.svgz country_AR.svgz country_AS.svgz country_AT.svgz country_AU.svgz country_AW.svgz
-flag_svgs += country_AX.svgz country_AZ.svgz country_BA.svgz country_BB.svgz country_BD.svgz country_BE.svgz country_BF.svgz
-flag_svgs += country_BG.svgz country_BH.svgz country_BI.svgz country_BJ.svgz country_BL.svgz country_BM.svgz country_BN.svgz
-flag_svgs += country_BO.svgz country_BR.svgz country_BS.svgz country_BT.svgz country_BV.svgz country_BW.svgz country_BY.svgz
-flag_svgs += country_BZ.svgz country_CA.svgz country_CC.svgz country_CD.svgz country_CF.svgz country_CG.svgz country_CH.svgz
-flag_svgs += country_CI.svgz country_CK.svgz country_CL.svgz country_CM.svgz country_CN.svgz country_CO.svgz country_CR.svgz
-flag_svgs += country_CU.svgz country_CV.svgz country_CX.svgz country_CY.svgz country_CZ.svgz country_DE.svgz country_DJ.svgz
-flag_svgs += country_DK.svgz country_DM.svgz country_DO.svgz country_DZ.svgz country_EC.svgz country_EE.svgz country_EG.svgz
-flag_svgs += country_EH.svgz country_ER.svgz country_ES.svgz country_ET.svgz country_FI.svgz country_FJ.svgz country_FK.svgz
-flag_svgs += country_FM.svgz country_FO.svgz country_FR.svgz country_GA.svgz country_GB.svgz country_GD.svgz country_GE.svgz
-flag_svgs += country_GF.svgz country_GG.svgz country_GH.svgz country_GI.svgz country_GL.svgz country_GM.svgz country_GN.svgz
-flag_svgs += country_GP.svgz country_GQ.svgz country_GR.svgz country_GS.svgz country_GT.svgz country_GU.svgz country_GW.svgz
-flag_svgs += country_GY.svgz country_HK.svgz country_HM.svgz country_HN.svgz country_HR.svgz country_HT.svgz country_HU.svgz
-flag_svgs += country_ID.svgz country_IE.svgz country_IL.svgz country_IM.svgz country_IN.svgz country_IO.svgz country_IQ.svgz
-flag_svgs += country_IR.svgz country_IS.svgz country_IT.svgz country_JE.svgz country_JM.svgz country_JO.svgz country_JP.svgz
-flag_svgs += country_KE.svgz country_KG.svgz country_KH.svgz country_KI.svgz country_KM.svgz country_KN.svgz country_KP.svgz
-flag_svgs += country_KR.svgz country_KW.svgz country_KY.svgz country_KZ.svgz country_LA.svgz country_LB.svgz country_LC.svgz
-flag_svgs += country_LI.svgz country_LK.svgz country_LR.svgz country_LS.svgz country_LT.svgz country_LU.svgz country_LV.svgz
-flag_svgs += country_LY.svgz country_MA.svgz country_MC.svgz country_MD.svgz country_ME.svgz country_MF.svgz country_MG.svgz
-flag_svgs += country_MH.svgz country_MK.svgz country_ML.svgz country_MM.svgz country_MN.svgz country_MO.svgz country_MP.svgz
-flag_svgs += country_MQ.svgz country_MR.svgz country_MS.svgz country_MT.svgz country_MU.svgz country_MV.svgz country_MW.svgz
-flag_svgs += country_MX.svgz country_MY.svgz country_MZ.svgz country_NA.svgz country_NC.svgz country_NE.svgz country_NF.svgz
-flag_svgs += country_NG.svgz country_NI.svgz country_NL.svgz country_NO.svgz country_NP.svgz country_NR.svgz country_NU.svgz
-flag_svgs += country_NZ.svgz country_OM.svgz country_PA.svgz country_PE.svgz country_PF.svgz country_PG.svgz country_PH.svgz
-flag_svgs += country_PK.svgz country_PL.svgz country_PM.svgz country_PN.svgz country_PR.svgz country_PS.svgz country_PT.svgz
-flag_svgs += country_PW.svgz country_PY.svgz country_QA.svgz country_RE.svgz country_RO.svgz country_RS.svgz country_RU.svgz
-flag_svgs += country_RW.svgz country_SA.svgz country_SB.svgz country_SC.svgz country_SD.svgz country_SE.svgz country_SG.svgz
-flag_svgs += country_SH.svgz country_SI.svgz country_SJ.svgz country_SK.svgz country_SL.svgz country_SM.svgz country_SN.svgz
-flag_svgs += country_SO.svgz country_SR.svgz country_ST.svgz country_SV.svgz country_SY.svgz country_SZ.svgz country_TC.svgz
-flag_svgs += country_TD.svgz country_TF.svgz country_TG.svgz country_TH.svgz country_TJ.svgz country_TK.svgz country_TL.svgz
-flag_svgs += country_TM.svgz country_TN.svgz country_TO.svgz country_TR.svgz country_TT.svgz country_TV.svgz country_TW.svgz
-flag_svgs += country_TZ.svgz country_UA.svgz country_UG.svgz country_UM.svgz country_US.svgz country_UY.svgz country_UZ.svgz
-flag_svgs += country_VA.svgz country_VC.svgz country_VE.svgz country_VG.svgz country_VI.svgz country_VN.svgz country_VU.svgz
-flag_svgs += country_WF.svgz country_WS.svgz country_YE.svgz country_YT.svgz country_ZA.svgz country_ZM.svgz country_ZW.svgz
-
-if USE_SVG
- image_DATA += $(svgs) $(nav_svgs) $(flag_svgs)
-endif
-
-if USE_SVG2PNG
-# Implicit rules for generating the PNG files. This only generates the
-# standard size; for additional sizes see below.
-%.png: $(srcdir)/%.svg
- SRCDIR=$(abs_srcdir) BUILDDIR=$(abs_builddir) $(srcdir)/navit_svg2png "@SVG2PNG@" "$@"
-%.png: $(srcdir)/%.svgz
- SRCDIR=$(abs_srcdir) BUILDDIR=$(abs_builddir) $(srcdir)/navit_svg2png "@SVG2PNG@" "$@"
-
-pngs = $(addsuffix .png,$(basename $(svgs)))
-xsize = $(word 1,$(subst x, ,$(scale)))
-ysize = $(word $(words $(scale)),$(subst x, ,$(scale)))
-comma =,
-
-# template to generate scaling rules for the various PNG sizes
-define scaling_rule_template
-%_$(1)_$(1).png: $(srcdir)/%.$(2)
- SRCDIR=$(abs_srcdir) BUILDDIR=$(abs_builddir) $(srcdir)/navit_svg2png "@SVG2PNG@" "$$@"
-endef
-
-# template to generate scaling rules for the default PNG size
-define scaling_rule_template_def
-$(basename $(1)).png: $(srcdir)/$(1)
- SRCDIR=$(abs_srcdir) BUILDDIR=$(abs_builddir) $(srcdir)/navit_svg2png "@SVG2PNG@" "$$@" "$(2)" "$(2)"
-endef
-
-
-# png images of the user interface and other, sizes e.g. "8,16,32,48,96"
-if USE_SVG2PNG_SCALES
-pngs += $(foreach scale, $(subst $(comma), ,@SVG2PNG_SCALES@), $(addsuffix _$(xsize)_$(ysize).png,$(basename $(svgs))))
-# create rules from template
-$(foreach extension,svg svgz, $(foreach size, $(subst $(comma), ,@SVG2PNG_SCALES@),$(eval $(call scaling_rule_template,$(size),$(extension)))))
-endif
-
-# png state flags
-if USE_SVG2PNG_SCALES_FLAG
-svg2png_scales_flag = $(subst $(comma), ,@SVG2PNG_SCALES_FLAG@)
-pngs += $(addsuffix .png,$(basename $(flag_svgs)))
-pngs += $(foreach scale, $(wordlist 2,100,$(svg2png_scales_flag)), $(addsuffix _$(xsize)_$(ysize).png,$(basename $(flag_svgs))))
-# create rules from templates
-$(foreach extension,svg svgz, $(foreach size, $(wordlist 2,100,$(svg2png_scales_flag)),$(eval $(call scaling_rule_template,$(size),$(extension)))))
-$(foreach img,$(flag_svgs), $(foreach size, $(firstword $(svg2png_scales_flag)),$(eval $(call scaling_rule_template_def,$(img),$(size)))))
-endif
-
-# png symbols for navigation
-if USE_SVG2PNG_SCALES_NAV
-pngs += $(foreach scale, $(subst $(comma), ,@SVG2PNG_SCALES_NAV@), $(addsuffix _$(xsize)_$(ysize).png,$(basename $(nav_svgs))))
-# create rules from template
-$(foreach extension,svg svgz, $(foreach size, $(subst $(comma), ,@SVG2PNG_SCALES_NAV@),$(eval $(call scaling_rule_template,$(size),$(extension)))))
-endif
-
-image_DATA += $(pngs)
-endif
-
-if !SUPPORT_WIN32
- DESKTOPFILEdir=$(datadir)/applications
- DESKTOPFILE_DATA = desktop_icons/navit.desktop
-
- ICON128dir=$(datadir)/icons/hicolor/128x128/apps
- ICON128_DATA = desktop_icons/128x128/navit.png
-
- ICON22dir=$(datadir)/icons/hicolor/22x22/apps
- ICON22_DATA = desktop_icons/22x22/navit.png
-endif
-
-EXTRA_DIST = $(image_DATA) $(DESKTOPFILE_DATA) $(ICON128_DATA) $(ICON22_DATA) navit_svg2png
-
-if USE_SVG2PNG
-clean:
- rm -f $(pngs)
-endif