summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorjoe <joe@61a7d7f5-40b7-0310-9c16-bb0ea8cb1845>2008-01-31 11:40:22 +0000
committerjoe <joe@61a7d7f5-40b7-0310-9c16-bb0ea8cb1845>2008-01-31 11:40:22 +0000
commit91d0fcf1f794acc90a671bf5557d2d2a505843f7 (patch)
tree2d7572c6c4f2dd15b07daa6abbf5b5897501cea2 /configure.in
parent50a193569c765191e14961718af2d004d184c7f1 (diff)
downloadneon-91d0fcf1f794acc90a671bf5557d2d2a505843f7.tar.gz
Add libneon-gnutls support library to allow use of external signing
callback with GnuTLS: * src/lib_gnutls.c, src/ne_gnutls.h, neon-gnutls.pc.in: New files. * src/ne_privssl.h (struct ne_ssl_context_s): Add sign_func, sign_data fields. * macros/neon.m4 (NEON_SSL): Define NE_SSL_LIBNAME; check for gnutls_sign_callback_set, add new exports NE_SSL_CFLAGS and NE_LIBSSL_LTFLAGS. Export NEON_LIBEXT in place of NEON_TARGET, NE_LIBNEON_LTFLAGS in place of NEON_LINK_FLAGS; * src/Makefile.in: Add and adjust targets to build libneon-gnutls iff configured with GnuTLS support. * Makefile.in (install-lib-ssl-no, install-lib-ssl-gnutls): New targets. * neon-config.in: Add --la-file=gnutls, --cflags=gnutls support. * src/ne_socket.c (ne_sock_connect_ssl): Set up the sign_func callback if non-NULL. * configure.in: Adjust for NEON_LINK_FLAGS rename. Define NE_LIBSSL_LTFLAGS. Generate neon-gnutls.pc. git-svn-id: http://svn.webdav.org/repos/projects/neon/trunk@1315 61a7d7f5-40b7-0310-9c16-bb0ea8cb1845
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 9 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 690c036..fdaf0a2 100644
--- a/configure.in
+++ b/configure.in
@@ -6,7 +6,7 @@ m4_define(ne_version, [m4_translit(m4_include(.version), [
AC_INIT(neon, ne_version, [neon@webdav.org])
-AC_COPYRIGHT([Copyright 2000-2005 Joe Orton and others
+AC_COPYRIGHT([Copyright 2000-2008 Joe Orton and others
This configure script may be copied, distributed and modified under the
terms of the GNU Library General Public license; see src/COPYING.LIB for
more details.])
@@ -138,15 +138,17 @@ fi
AC_SUBST(NEON_PC_LIBS)
# Pass the interface version on to libtool when linking libneon.la
-NEON_LINK_FLAGS="-version-info ${NE_LIBTOOL_VERSINFO}"
+NE_LIBNEON_LTFLAGS="-version-info ${NE_LIBTOOL_VERSINFO}"
# If any non-default ABI variations are used, add them to the SONAME:
if test "x${NE_LIBTOOL_RELEASE}y" != "xy"; then
- NEON_LINK_FLAGS="${NEON_LINK_FLAGS} -release ${NE_LIBTOOL_RELEASE}"
+ NE_LIBNEON_LTFLAGS="${NE_LIBNEON_LTFLAGS} -release ${NE_LIBTOOL_RELEASE}"
fi
# Library-internal symbols are in the ne__ namespace: tell libtool
# to not export these from the built library if possible.
-NEON_LINK_FLAGS="$NEON_LINK_FLAGS -export-symbols-regex '^ne_[[^_]]'"
+NE_LIBNEON_LTFLAGS="$NE_LIBNEON_LTFLAGS -export-symbols-regex '^ne_[[^_]]'"
+
+NE_LIBSSL_LTFLAGS="-version-info 1:0:0"
# Bundled language catalogs
ALL_LINGUAS="cs de fr ja nn pl ru tr zh"
@@ -154,6 +156,9 @@ AC_SUBST(ALL_LINGUAS)
AC_CONFIG_FILES([neon-config], [chmod +x neon-config])
AC_CONFIG_FILES([Makefile src/Makefile test/Makefile neon.pc])
+if test x$NE_SSL_LIBNAME = xgnutls; then
+ AC_CONFIG_FILES([neon-gnutls.pc])
+fi
AC_SUBST(NEON_VERSION)
AC_SUBST(NEON_BUILD_BUNDLED)