summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJakub Stasiak <jakub@stasiak.at>2020-06-19 00:58:25 +0200
committerJakub Stasiak <jakub@stasiak.at>2020-06-19 01:13:35 +0200
commitbeca47dccb09fecc38cf387852af92792bdfa082 (patch)
treeb70ed7feb8240e551fd1c361474c19ae0f792653 /setup.py
parent45acdfffbfe7aa24decaabe6c4a8e0df3f4457c5 (diff)
downloadnetaddr-beca47dccb09fecc38cf387852af92792bdfa082.tar.gz
Revert "- PKG-INFO metadata generation seems to be broken (lists maintainer as author on PyPI - mutually exclusive?)"
More than a year after the original commit this has been fixed in setuptools[1] so we can go back to the way it was intended to be. This reverts commit 34ff560464757cfb9dd59cabae9cb5d099d32c87. [1] https://github.com/pypa/setuptools/pull/1294
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 4fea507..80ce8c0 100644
--- a/setup.py
+++ b/setup.py
@@ -155,8 +155,10 @@ def main():
sys.stdout.write("To install, run 'python setup.py install'\n\n")
setup_options = dict(
- author='David P. D. Moss, Stefan Nordhausen et al',
+ author='David P. D. Moss et al',
author_email='drkjam@gmail.com',
+ maintainer='Stefan Nordhausen',
+ maintainer_email='stefan.nordhausen@immobilienscout24.de',
classifiers=classifiers,
description='A network address manipulation library for Python',
download_url='https://pypi.org/project/netaddr/',