summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNiels Möller <nisse@lysator.liu.se>2011-11-24 12:22:40 +0100
committerNiels Möller <nisse@lysator.liu.se>2011-11-24 12:22:40 +0100
commit08b08e081b3fcf4b68ddcd5396caf6eac4d2e9f1 (patch)
treeb4a56ac24a7135ad29b35d3668b0d4b06fc6af38 /configure.ac
parent65c053688c2071e96d232a6a98d857d37f83b242 (diff)
downloadnettle-08b08e081b3fcf4b68ddcd5396caf6eac4d2e9f1.tar.gz
(EMULATOR): Set for cross compilation only.
Rev: nettle/ChangeLog:1.234 Rev: nettle/configure.ac:1.50
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 10 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 6b6ddf36..3849947c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -273,15 +273,16 @@ case "$host_os" in
LIBHOGWEED_FORLINK='cyghogweed-$(LIBHOGWEED_MAJOR)-$(LIBHOGWEED_MINOR).dll'
;;
esac
- # FIXME: Support native compilation using mingw on windows.
- case "$ABI" in
- 64)
- EMULATOR=wine64
- ;;
- *)
- EMULATOR=wine
- ;;
- esac
+ if test "x$cross_compiling" = xyes ; then
+ case "$ABI" in
+ 64)
+ EMULATOR=wine64
+ ;;
+ *)
+ EMULATOR=wine
+ ;;
+ esac
+ fi
LIBNETTLE_SONAME=''
LIBNETTLE_FILE='libnettle.dll.a'
LIBNETTLE_FILE_SRC='$(LIBNETTLE_FILE)'