summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNiels Möller <nisse@lysator.liu.se>2017-08-26 09:32:25 +0200
committerNiels Möller <nisse@lysator.liu.se>2017-08-27 21:05:54 +0200
commitb7052093931d69d3626a54d59783e0d9e48ea20f (patch)
tree0f4b908bf5b41888505acdde224043744c3bcc5c /configure.ac
parent0bf64256ecf10af974c1970d87ffad19cbce7b51 (diff)
downloadnettle-b7052093931d69d3626a54d59783e0d9e48ea20f.tar.gz
Separate the two uses of the configured value GMP_NUMB_BITS.
In version.h, GMP_NUMB_BITS is needed only for mini-gmp builds. In non-mini-gmp builds, substitute a dummy value there, to make the contents of this header file platform independent. In Makefile, we always need a properly configured value, and do this with the renamed variable NUMB_BITS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1d1951b5..9b5f11f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -268,7 +268,16 @@ if test "x$enable_public_key" = "xyes" ; then
fi
fi
-GMP_NUMB_BITS="$nettle_cv_gmp_numb_bits"
+# Substituted in Makefile, passed on to the eccdata command.
+NUMB_BITS="$nettle_cv_gmp_numb_bits"
+AC_SUBST([NUMB_BITS])
+
+# Substituted in version.h, used only with mini-gmp.
+if test "x$enable_mini_gmp" = "xyes" ; then
+ GMP_NUMB_BITS="$NUMB_BITS"
+else
+ GMP_NUMB_BITS="n/a"
+fi
AC_SUBST([GMP_NUMB_BITS])
# Figure out ABI. Currently, configurable only by setting CFLAGS.