summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSteve Dickson <steved@redhat.com>2015-09-15 14:16:42 -0400
committerSteve Dickson <steved@redhat.com>2015-09-15 14:24:33 -0400
commit017164521b94018bd143b879b0e858d98cca83e8 (patch)
tree3a26faa5309c9953b151d12c0dcd7b0926678c5a /configure.ac
parent67a435bbf5015d8d2f6008744cadab4c4ede7c07 (diff)
downloadnfs-utils-017164521b94018bd143b879b0e858d98cca83e8.tar.gz
configure.ac: with-systemd flag not using default directory
The with-systemd config flag was not using the default directory when a directory was not given Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 926b044..7d08e1e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,7 +59,14 @@ unitdir=/usr/lib/systemd/system
AC_ARG_WITH(systemd,
[AC_HELP_STRING([--with-systemd@<:@=unit-dir-path@:>@],
[install systemd unit files @<:@Default: no, and path defaults to /usr/lib/systemd/system if not given@:>@])],
- test "$withval" = "no" && use_systemd=0 || unitdir=$withval use_systemd=1
+ if test "$withval" != "no" ; then
+ use_systemd=1
+ if test "$withval" != "yes" ; then
+ unitdir=$withval
+ fi
+ else
+ use_systemd=0
+ fi
)
AM_CONDITIONAL(INSTALL_SYSTEMD, [test "$use_systemd" = 1])
AC_SUBST(unitdir)