summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKinglong Mee <kinglongmee@gmail.com>2015-05-06 15:04:57 -0400
committerSteve Dickson <steved@redhat.com>2015-05-06 15:04:57 -0400
commit441a3183399a423a3c86675c7c5395a1514b8a1d (patch)
tree7678986822146087b8fe970a3c9fd208b1387aed /configure.ac
parent51ec5b18dba93ae816973f098d179826f243655e (diff)
downloadnfs-utils-441a3183399a423a3c86675c7c5395a1514b8a1d.tar.gz
configure.ac: fix configure fail with --disable-mount
Configure fail as, ./configure --disable-mount : checking for suitable libblkid version... yes checking for mnt_context_do_mount in -lmount... no configure: error: libmount needed Signed-off-by: Kinglong Mee <kinglongmee@gmail.com> Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 21be2bd..60ca4f9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -163,6 +163,8 @@ if test "$enable_mount" = yes; then
[Link mount.nfs with libmount @<:@default=no@:>@])],
enable_libmount=$enableval,
enable_libmount=no)
+else
+ enable_libmount=no
fi
AC_ARG_ENABLE(tirpc,
@@ -346,7 +348,7 @@ AC_SUBST(LIBBSD)
AC_SUBST(LIBBLKID)
AC_SUBST(LIBDL)
-if test "$enable_libmount" != no; then
+if test "$enable_libmount" = yes; then
AC_CHECK_LIB(mount, mnt_context_do_mount, [LIBMOUNT="-lmount"], AC_MSG_ERROR([libmount needed]))
AC_CHECK_HEADER(libmount/libmount.h, , AC_MSG_ERROR([Cannot find libmount header file libmount/libmount.h]))
fi