summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChuck Lever <chuck.lever@oracle.com>2018-02-07 13:29:47 -0500
committerSteve Dickson <steved@redhat.com>2018-02-07 13:43:35 -0500
commitdcb0d90609ff280335b2375fd85f71d58e468b48 (patch)
tree5b2a293eac5d64dd33198ed5587dc416b5fcbd71 /configure.ac
parent6562127d8e67ddba70f67d8096ac2d59f5ef76aa (diff)
downloadnfs-utils-dcb0d90609ff280335b2375fd85f71d58e468b48.tar.gz
Add infrastructure for libjunction
The source code for libjunction used to be maintained in fedfs-utils, but fedfs-utils is being retired. Although interest in FedFS junctions has waned, NFS basic junctions are still appealing enough that we've decided we want to continue supporting them. Therefore this patch moves the non-LDAP parts of libjunction into nfs-utils, to enable nfs-utils to also support the user-visible pieces of NFS basic junctions. I've added yet another configure command line option to control whether libjunction is built. It defaults to "disabled" for the moment. Reasons you might want to leave it disabled: - Your distribution still provides fedfs-utils, which already has a working libjunction which is installed separately - Your distribution does not provide libxml2, which is required to support libjunction When it's disabled, nfs-utils builds just like it did before this patch, and there's no new dependency on libxml2. Signed-off-by: Chuck Lever <chuck.lever@oracle.com> Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2d328db..7c5e055 100644
--- a/configure.ac
+++ b/configure.ac
@@ -180,6 +180,13 @@ else
enable_libmount=no
fi
+AC_ARG_ENABLE(junction,
+ [AC_HELP_STRING([--enable-junction],
+ [enable support for NFS junctions @<:@default=no@:>@])],
+ enable_junction=$enableval,
+ enable_junction=no)
+AM_CONDITIONAL(CONFIG_JUNCTION, [test "$enable_junction" = "yes" ])
+
AC_ARG_ENABLE(tirpc,
[AC_HELP_STRING([--disable-tirpc],
[disable use of TI-RPC library @<:@default=no@:>@])],
@@ -244,6 +251,9 @@ AC_LIBTIRPC
dnl Check for -lcap
AC_LIBCAP
+dnl Check for -lxml2
+AC_LIBXML2
+
# Check whether user wants TCP wrappers support
AC_TCP_WRAPPERS
@@ -572,6 +582,7 @@ AC_CONFIG_FILES([
support/include/sys/fs/Makefile
support/include/sys/Makefile
support/include/Makefile
+ support/junction/Makefile
support/misc/Makefile
support/nfs/Makefile
support/nsm/Makefile