summaryrefslogtreecommitdiff
path: root/support/Makefile.am
diff options
context:
space:
mode:
authorChuck Lever <chuck.lever@oracle.com>2018-02-07 13:29:47 -0500
committerSteve Dickson <steved@redhat.com>2018-02-07 13:43:35 -0500
commitdcb0d90609ff280335b2375fd85f71d58e468b48 (patch)
tree5b2a293eac5d64dd33198ed5587dc416b5fcbd71 /support/Makefile.am
parent6562127d8e67ddba70f67d8096ac2d59f5ef76aa (diff)
downloadnfs-utils-dcb0d90609ff280335b2375fd85f71d58e468b48.tar.gz
Add infrastructure for libjunction
The source code for libjunction used to be maintained in fedfs-utils, but fedfs-utils is being retired. Although interest in FedFS junctions has waned, NFS basic junctions are still appealing enough that we've decided we want to continue supporting them. Therefore this patch moves the non-LDAP parts of libjunction into nfs-utils, to enable nfs-utils to also support the user-visible pieces of NFS basic junctions. I've added yet another configure command line option to control whether libjunction is built. It defaults to "disabled" for the moment. Reasons you might want to leave it disabled: - Your distribution still provides fedfs-utils, which already has a working libjunction which is installed separately - Your distribution does not provide libxml2, which is required to support libjunction When it's disabled, nfs-utils builds just like it did before this patch, and there's no new dependency on libxml2. Signed-off-by: Chuck Lever <chuck.lever@oracle.com> Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'support/Makefile.am')
-rw-r--r--support/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/support/Makefile.am b/support/Makefile.am
index 8365d3b..c962d4d 100644
--- a/support/Makefile.am
+++ b/support/Makefile.am
@@ -6,6 +6,10 @@ if CONFIG_NFSV4
OPTDIRS += nfsidmap
endif
+if CONFIG_JUNCTION
+OPTDIRS += junction
+endif
+
SUBDIRS = export include misc nfs nsm $(OPTDIRS)
MAINTAINERCLEANFILES = Makefile.in