summaryrefslogtreecommitdiff
path: root/systemd/Makefile.am
diff options
context:
space:
mode:
authorTrond Myklebust <trond.myklebust@hammerspace.com>2019-05-29 13:19:03 -0400
committerSteve Dickson <steved@redhat.com>2019-06-10 09:50:38 -0400
commit41bd29fc5250f43f989b22eb5f2bf86b3db6c9b0 (patch)
tree40465f50fed8c29f9a8154de1855d78271f0a5c9 /systemd/Makefile.am
parentdcd2c5fb686c22838fa8b07da66a7df7729388b4 (diff)
downloadnfs-utils-41bd29fc5250f43f989b22eb5f2bf86b3db6c9b0.tar.gz
Add a helper to return the real path given an export entry
Add a helper that can prepend the nfsd root directory path in order to allow mountd to perform its comparisons with mtab etc. Signed-off-by: Trond Myklebust <trond.myklebust@hammerspace.com> Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'systemd/Makefile.am')
-rw-r--r--systemd/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/systemd/Makefile.am b/systemd/Makefile.am
index d54518b..590258a 100644
--- a/systemd/Makefile.am
+++ b/systemd/Makefile.am
@@ -54,7 +54,8 @@ rpc_pipefs_generator_SOURCES = $(COMMON_SRCS) rpc-pipefs-generator.c
nfs_server_generator_LDADD = ../support/export/libexport.a \
../support/nfs/libnfs.la \
- ../support/misc/libmisc.a
+ ../support/misc/libmisc.a \
+ $(LIBPTHREAD)
rpc_pipefs_generator_LDADD = ../support/nfs/libnfs.la