summaryrefslogtreecommitdiff
path: root/systemd/Makefile.am
diff options
context:
space:
mode:
authorSalvatore Bonaccorso <carnil@debian.org>2022-12-05 15:28:25 -0500
committerSteve Dickson <steved@redhat.com>2022-12-05 15:59:12 -0500
commit89ea291577cf3b01ec20883c9d0a8a3c8c68d9b2 (patch)
tree28ecb2abf34ccaf398ef1627397f41453b06b8a5 /systemd/Makefile.am
parent580ac005d11ddb9a9622e380ba8e947ad743a38f (diff)
downloadnfs-utils-89ea291577cf3b01ec20883c9d0a8a3c8c68d9b2.tar.gz
Revert "configure: make modprobe.d directory configurable
This reverts commit 7d76dd2e6f09a141eb6303b7343baa5c4f9c85ad. This is part of the full revert of adding support via modprobe.d configuration to set sysctl settings of NFS-related modules when loading the modules. The approach caused problems with sysctl from busybox and with kmod as reported in Debian (https://bugs.debian.org/1024082). Signed-off-by: Salvatore Bonaccorso <carnil@debian.org> Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'systemd/Makefile.am')
-rw-r--r--systemd/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/systemd/Makefile.am b/systemd/Makefile.am
index 7b5ab84..63a50bf 100644
--- a/systemd/Makefile.am
+++ b/systemd/Makefile.am
@@ -82,7 +82,5 @@ install-data-hook: $(unit_files) $(modprobe_files)
else
install-data-hook: $(modprobe_files)
endif
-if INSTALL_MODPROBEDIR
- mkdir -p $(DESTDIR)$(modprobedir)
- cp $(modprobe_files) $(DESTDIR)$(modprobedir)
-endif
+ mkdir -p $(DESTDIR)/usr/lib/modprobe.d
+ cp $(modprobe_files) $(DESTDIR)/usr/lib/modprobe.d/