summaryrefslogtreecommitdiff
path: root/systemd/Makefile.am
diff options
context:
space:
mode:
authorNeilBrown <neilb@suse.com>2015-11-02 08:27:59 -0500
committerSteve Dickson <steved@redhat.com>2015-11-02 08:55:04 -0500
commitbbcb9b79fbe77e133fddf921c09dc757947c031b (patch)
tree53d15a153c6fce2017b19a6acc5184ff814ddca3 /systemd/Makefile.am
parent6597e3910b39a052dc98a32d43fe0900ec81643e (diff)
downloadnfs-utils-bbcb9b79fbe77e133fddf921c09dc757947c031b.tar.gz
systemd/Makefile: only install rpc-svcgssd.service if it is required.
If we build without rpc-svcgssd (the default), don't install matching .service file. Signed-off-by: NeilBrown <neilb@suse.com> Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'systemd/Makefile.am')
-rw-r--r--systemd/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/systemd/Makefile.am b/systemd/Makefile.am
index 0331926..03f96e9 100644
--- a/systemd/Makefile.am
+++ b/systemd/Makefile.am
@@ -28,9 +28,13 @@ endif
if CONFIG_GSS
unit_files += \
auth-rpcgss-module.service \
- rpc-gssd.service \
+ rpc-gssd.service
+
+if CONFIG_SVCGSS
+unit_files += \
rpc-svcgssd.service
endif
+endif
EXTRA_DIST = $(unit_files)