summaryrefslogtreecommitdiff
path: root/systemd/Makefile.am
diff options
context:
space:
mode:
authorSteve Dickson <steved@redhat.com>2021-02-19 14:56:33 -0500
committerSteve Dickson <steved@redhat.com>2021-02-19 14:56:33 -0500
commitc75159a35ca3b1964d753ed5693077db4b3dcf4c (patch)
tree6adb8ddeef4cd2ff53f126df7f72f8a894060b08 /systemd/Makefile.am
parentb5aa8378e1a100898d8e0dd628eb704c68667027 (diff)
downloadnfs-utils-c75159a35ca3b1964d753ed5693077db4b3dcf4c.tar.gz
exportd: Added config variable to compile in the NFSv4 only server.nfs-utils-2-5-3-rc6
Added the --enable-nfsv4server configuration flag that will compile/install nfsv4.exportd and install the systemd unit files. Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'systemd/Makefile.am')
-rw-r--r--systemd/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/systemd/Makefile.am b/systemd/Makefile.am
index 5251f23..650ad25 100644
--- a/systemd/Makefile.am
+++ b/systemd/Makefile.am
@@ -17,7 +17,11 @@ unit_files = \
if CONFIG_NFSV4
unit_files += \
- nfs-idmapd.service \
+ nfs-idmapd.service
+endif
+
+if CONFIG_NFSV4SERVER
+unit_files += \
nfsv4-exportd.service \
nfsv4-server.service
endif