summaryrefslogtreecommitdiff
path: root/tools/rpcctl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/rpcctl/Makefile.am')
-rw-r--r--tools/rpcctl/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/tools/rpcctl/Makefile.am b/tools/rpcctl/Makefile.am
new file mode 100644
index 0000000..33fb431
--- /dev/null
+++ b/tools/rpcctl/Makefile.am
@@ -0,0 +1,13 @@
+## Process this file with automake to produce Makefile.in
+PYTHON_FILES = rpcctl.py
+
+man8_MANS = rpcctl.man
+
+EXTRA_DIST = $(man8_MANS) $(PYTHON_FILES)
+
+all-local: $(PYTHON_FILES)
+
+install-data-hook:
+ $(INSTALL) -m 755 rpcctl.py $(DESTDIR)$(sbindir)/rpcctl
+
+MAINTAINERCLEANFILES=Makefile.in