summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL11
1 files changed, 9 insertions, 2 deletions
diff --git a/Makefile.PL b/Makefile.PL
index af4730c..b29cf02 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,12 +1,13 @@
use strict;
use warnings;
+use utf8;
use ExtUtils::MakeMaker;
WriteMakefile(
NAME => 'Ninka',
VERSION_FROM => 'lib/Ninka.pm',
ABSTRACT_FROM => 'lib/Ninka.pm',
- LICENSE => 'agpl_3',
+ LICENSE => 'gpl_2',
AUTHOR => [
'Daniel M. German <dmg@uvic.ca>',
'Yuki Manabe <y-manabe@ist.osaka-u.ac.jp>',
@@ -17,21 +18,27 @@ WriteMakefile(
'ExtUtils::MakeMaker' => '6.52',
},
PREREQ_PM => {
+ 'DBI' => '0',
+ 'DBD::SQLite' => '0',
'File::Basename' => '0',
+ 'File::Find' => '0',
'File::Spec::Functions' => '0',
+ 'File::Temp' => '0',
'Getopt::Std' => '0',
'IPC::Open3' => '0',
+ 'Spreadsheet::WriteExcel' => '0',
},
TEST_REQUIRES => {
'File::Temp' => '0',
'Test::More' => '0.98',
+ 'Test::Pod' => '1.00',
'Test::Strict' => '0',
},
META_MERGE => {
resources => {
homepage => 'http://ninka.turingmachine.org/',
repository => 'https://github.com/dmgerman/ninka',
- license => 'http://www.gnu.org/licenses/agpl-3.0.html',
+ license => 'http://www.gnu.org/licenses/gpl-2.0.html',
},
},
);