summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJannis Pohlmann <jannis.pohlmann@codethink.co.uk>2012-06-11 17:27:13 +0100
committerJannis Pohlmann <jannis.pohlmann@codethink.co.uk>2012-06-11 17:27:13 +0100
commit2b0198f9bc0c7458ae06dea228a91f797188fd13 (patch)
treefda87b28f4a773466875f12618ecc9d1f40a5957 /configure.ac
parentb993f6e9d3366dc3b31d1e2e6c4e91a4bff46554 (diff)
downloadnode-startup-controller-2b0198f9bc0c7458ae06dea228a91f797188fd13.tar.gz
Add skeleton for the org.genivi.LUCHandler1 service implementation
This skeleton has stubs for the implementation of the Register() and Deregister() methods. It currently uses the session bus to make it easier to test as a regular user. The implementation does not use the DLT yet, neither does it register with systemd's watchdog mechanism. It also does not register with the NSM as a shutdown consumer yet. GDBus appears to need a little help to add parameters to the generated C functions, so we'll probably have to extend the XML interface definition with a few annotations.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bdd0bab..74f76df 100644
--- a/configure.ac
+++ b/configure.ac
@@ -57,7 +57,7 @@ dnl ***************************************
dnl *** Check for standard header files ***
dnl ***************************************
AC_HEADER_STDC()
-AC_CHECK_HEADERS([])
+AC_CHECK_HEADERS([stdlib.h])
dnl ************************************
dnl *** Check for standard functions ***