summaryrefslogtreecommitdiff
path: root/NodeStateMachineStub/CMakeLists.txt
diff options
context:
space:
mode:
authorMonika Forstner <Monika_Forstner@mentor.com>2020-09-16 10:20:03 +0200
committerMonika Forstner <Monika_Forstner@mentor.com>2020-09-16 10:50:27 +0200
commit2fb502b4bc23aa13fee1db3395b3cae5e34cc871 (patch)
treed9cd2c64522f190500dc53291b4fbcf5100b9720 /NodeStateMachineStub/CMakeLists.txt
parent253d10aada6bf5cdfe307aaff55363f08194c85e (diff)
downloadnode-state-manager-release_NSM_CommonAPI.tar.gz
NSM Release 3.0release_NSM_CommonAPI
Diffstat (limited to 'NodeStateMachineStub/CMakeLists.txt')
-rw-r--r--NodeStateMachineStub/CMakeLists.txt50
1 files changed, 50 insertions, 0 deletions
diff --git a/NodeStateMachineStub/CMakeLists.txt b/NodeStateMachineStub/CMakeLists.txt
new file mode 100644
index 0000000..311e261
--- /dev/null
+++ b/NodeStateMachineStub/CMakeLists.txt
@@ -0,0 +1,50 @@
+#######################################################################################################################
+#
+# Copyright (C) 2020 Mentor Graphics (Deutschland) GmbH
+#
+# Author: Vignesh_Rajendran@mentor.com
+#
+# CMake file of NodeStateMachineStub
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#######################################################################################################################
+
+cmake_minimum_required(VERSION 3.7.2 FATAL_ERROR)
+
+project(NodeStateMachineStub LANGUAGES CXX)
+
+set(SOURCE_FILES NodeStateMachine.cpp)
+
+if(WITH_TESTS)
+ file(GLOB SOURCE_FILES *.cpp)
+endif(WITH_TESTS)
+
+add_library(NodeStateMachineStub SHARED ${SOURCE_FILES})
+
+target_compile_features(NodeStateMachineStub PRIVATE cxx_std_11)
+
+target_compile_options(NodeStateMachineStub PRIVATE -Werror -pthread)
+
+target_link_libraries(NodeStateMachineStub PRIVATE
+ ${COMMONAPI_LIBS}
+ org.genivi.nodestatemanager.commonapi.core.stub
+ org.genivi.nodestatemanager.commonapi.someip.stub
+ pthread)
+
+install(TARGETS NodeStateMachineStub DESTINATION lib)
+
+install(TARGETS NodeStateMachineStub
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+
+install(
+ DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
+ FILES_MATCHING
+ PATTERN "*.h"
+ PATTERN "*.hpp")
+