summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index fcc9abc..50165fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,7 +15,7 @@
#######################################################################################################################
# Initialize autoconf
-AC_INIT([node-state-manager],[2.0.0])
+AC_INIT([node-state-manager],[2.0.1])
AC_COPYRIGHT([Copyright (c) 2012 Continental Automotive GmbH])
AC_PREREQ([2.50])
@@ -47,6 +47,13 @@ PKG_CHECK_MODULES([DBUS], [dbus-1 >= 1.4.10])
PKG_CHECK_MODULES([SYSTEMD], [libsystemd-daemon >= 37 ])
PKG_CHECK_MODULES([PCL], [persistence_client_library >= 0.6.0 ])
+# Choose NodeStateMachine
+AC_ARG_WITH([nsmc],
+ [AS_HELP_STRING([--with-nsmc], [Set the NodeStateMachine (default NodeStateMachineStub)])],
+ [nsmc=$withval], [nsmc="NodeStateMachineStub"])
+
+AC_SUBST(NSMC, $nsmc)
+
# Derive path for storing systemd service files (e. g. /lib/systemd/system)
AC_ARG_WITH([systemdsystemunitdir],
AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files]),
@@ -83,8 +90,8 @@ AC_SUBST([dbusinterfacesdir], [$with_dbusinterfacesdir])
# Define configure output
AC_CONFIG_FILES([Makefile
NodeStateManager/Makefile
- NodeStateTest/Makefile
NodeStateAccess/Makefile
+ NodeStateMachineTest/Makefile
NodeStateMachineStub/Makefile
NodeStateManager/config/nodestatemanager-daemon.service
NodeStateManager/config/org.genivi.NodeStateManager.LifeCycleControl.service