summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorsamr7 <samr7@126591fb-c623-4b62-a76d-97a8e4f34109>2008-10-18 19:22:48 +0000
committersamr7 <samr7@126591fb-c623-4b62-a76d-97a8e4f34109>2008-10-18 19:22:48 +0000
commit91ce492958db5a000a39a26c47aacee6b198308e (patch)
treed1203387372d13c0204ff6da049943ae5ad8f0ff /configure.in
parent28e5ff922876734bd1ed1a1925a25929686c9dbd (diff)
downloadnohands-91ce492958db5a000a39a26c47aacee6b198308e.tar.gz
Fix problems related to libspeexdsp being deconfigured.
Don't expose DSP properties when it's not. hfconsole breaks in this configuration, but we'll fix that another day. git-svn-id: http://nohands.svn.sourceforge.net/svnroot/nohands/trunk@6 126591fb-c623-4b62-a76d-97a8e4f34109
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in30
1 files changed, 30 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b288caf..66a92b6 100644
--- a/configure.in
+++ b/configure.in
@@ -290,6 +290,21 @@ if test $use_alsa = "yes"; then
AC_DEFINE([USE_ALSA_SOUNDIO], [], [Enable support for libasound])
libhfp_CXXFLAGS="$libhfp_CXXFLAGS $ALSA_CFLAGS"
libhfp_LIBS="$libhfp_LIBS $ALSA_LIBS"
+else
+ if test $want_alsa != "no"; then
+ echo "***"
+ echo "***"
+ echo "*** WARNING: Support for ALSA is being omitted"
+ echo "*** WARNING: This probably isn't what you want"
+ echo "*** WARNING: Install libasound development package"
+ echo "***"
+ echo "***"
+ echo -n -e "\a"
+ sleep 1
+ echo -n -e "\a"
+ sleep 1
+ echo -n -e "\a"
+ fi
fi
if test $want_oss = "yes"; then
AC_DEFINE([USE_OSS_SOUNDIO], [], [Enable support for OSS])
@@ -303,6 +318,21 @@ if test $use_speexdsp = "yes"; then
AC_DEFINE([USE_SPEEXDSP], [], [Enable support for libspeexdsp])
libhfp_CXXFLAGS="$libhfp_CXXFLAGS $SPEEXDSP_CFLAGS"
libhfp_LIBS="$libhfp_LIBS $SPEEXDSP_LIBS"
+else
+ if test $want_speexdsp != "no"; then
+ echo "***"
+ echo "***"
+ echo "*** WARNING: Support for libspeexdsp is being omitted"
+ echo "*** WARNING: This probably isn't what you want"
+ echo "*** WARNING: Install libspeexdsp development package"
+ echo "***"
+ echo "***"
+ echo -n -e "\a"
+ sleep 1
+ echo -n -e "\a"
+ sleep 1
+ echo -n -e "\a"
+ fi
fi
if test $use_nghost = "yes"; then