summaryrefslogtreecommitdiff
path: root/bin/Makefile.am
diff options
context:
space:
mode:
authorBen Skeggs <bskeggs@redhat.com>2012-05-22 10:59:14 +1000
committerBen Skeggs <bskeggs@redhat.com>2013-01-09 14:32:47 +1000
commit827ac5471ac6b03d7a74e8fe0805787b0b3c8364 (patch)
treec493524ff33dedb9f6aa54b51832b4947921f75b /bin/Makefile.am
downloadnouveau-827ac5471ac6b03d7a74e8fe0805787b0b3c8364.tar.gz
initial import of nouveau kernel module core, some simple tools, and drm
Ignore (or, if you're really keen, fix) any of the horrors that are part of the emulate-linux-on-libpciaccess (lib/) layer. When I started down this path I was only aiming to prototype the reworked driver core, and never actually intended on going quite this far with things, but it turns out that being able to develop and test the nouveau core from userspace is *very* useful. This tree is based on the code available as of Linux 3.8-rc2. Signed-off-by: Ben Skeggs <bskeggs@redhat.com>
Diffstat (limited to 'bin/Makefile.am')
-rw-r--r--bin/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/bin/Makefile.am b/bin/Makefile.am
new file mode 100644
index 000000000..998e5ebe4
--- /dev/null
+++ b/bin/Makefile.am
@@ -0,0 +1,15 @@
+bin_PROGRAMS = \
+ nv_rd08 nv_rd16 nv_rd32 nv_wr08 nv_wr16 nv_wr32 \
+ nv_rf08 nv_rf16 nv_rf32 nv_wf08 nv_wf16 nv_wf32 \
+ nv_ri08 nv_ri16 nv_ri32 nv_wi08 nv_wi16 nv_wi32 \
+ nv_rv08 nv_rv16 nv_rv32 nv_wv08 nv_wv16 nv_wv32 \
+ nv_rs08 nv_rs16 nv_rs32 nv_ws08 nv_ws16 nv_ws32 \
+ nv_disp
+
+AM_CPPFLAGS = -I$(top_srcdir)/nvkm/include \
+ -I$(top_srcdir)/nvkm \
+ -I$(top_srcdir)/lib/
+
+LDADD = -lpciaccess \
+ $(top_srcdir)/lib/libpciaccessos.la \
+ $(top_srcdir)/nvkm/libnouveau.la