summaryrefslogtreecommitdiff
path: root/nvif/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'nvif/Makefile.am')
-rw-r--r--nvif/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/nvif/Makefile.am b/nvif/Makefile.am
new file mode 100644
index 000000000..23e331733
--- /dev/null
+++ b/nvif/Makefile.am
@@ -0,0 +1,12 @@
+lib_LTLIBRARIES = libnvif.la
+
+# XXX: /lib shouldn't be here, but is needed while we include core headers
+libnvif_la_CPPFLAGS = -I${top_srcdir}/nvkm/include \
+ -I${top_srcdir}/nvkm \
+ -I${top_srcdir}/lib \
+ -I${top_srcdir}
+libnvif_la_LIBADD = $(top_srcdir)/lib/libpciaccessos.la
+libnvif_la_SOURCES = object.c \
+ client.c \
+ device.c \
+ notify.c