summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaolan McMahon <caolan@caolanmcmahon.com>2012-02-26 18:40:34 -0800
committerCaolan McMahon <caolan@caolanmcmahon.com>2012-02-26 18:40:34 -0800
commitef0ed4d756ca36e8015b6c7a9c67e064eae6f699 (patch)
tree0c8901aaa396ae22020ed53b04cf6d4995b3b319
parent1ae1775e8e1287a4ffe26a9bead498e47e22a956 (diff)
downloadasync-ef0ed4d756ca36e8015b6c7a9c67e064eae6f699.tar.gz
use uglify, nodeunit and nodelint directly from node_modules
-rw-r--r--Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 8b573fd..bad647c 100644
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,9 @@
PACKAGE = asyncjs
NODEJS = $(if $(shell test -f /usr/bin/nodejs && echo "true"),nodejs,node)
CWD := $(shell pwd)
-WITH_NODEUNIT = PATH=$(CWD)/node_modules/nodeunit/bin:$(PATH)
-WITH_UGLIFY = PATH=$(CWD)/node_modules/uglify-js/bin:$(PATH)
-WITH_NODELINT = PATH=$(CWD)/node_modules/nodelint/bin:$(PATH)
+NODEUNIT = $(CWD)/node_modules/nodeunit/bin/nodeunit
+UGLIFY = $(CWD)/node_modules/uglify-js/bin/uglifyjs
+NODELINT = $(CWD)/node_modules/nodelint/nodelint
BUILDDIR = dist
@@ -11,15 +11,15 @@ all: clean test build
build: $(wildcard lib/*.js)
mkdir -p $(BUILDDIR)
- $(WITH_UGLIFY) uglifyjs lib/async.js > $(BUILDDIR)/async.min.js
+ $(UGLIFY) lib/async.js > $(BUILDDIR)/async.min.js
test:
- $(WITH_NODEUNIT) nodeunit test
+ $(NODEUNIT) test
clean:
rm -rf $(BUILDDIR)
lint:
- $(WITH_NODELINT) nodelint --config nodelint.cfg lib/async.js
+ $(NODELINT) --config nodelint.cfg lib/async.js
.PHONY: test build all