summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGraeme Yeates <yeatesgraeme@gmail.com>2015-06-29 17:36:26 -0400
committerGraeme Yeates <yeatesgraeme@gmail.com>2015-06-29 17:36:26 -0400
commit70ae2fbc151baa88a9cec1f6ad0939ec584e7192 (patch)
treecddd40552677a491cce94aa11e57e6885be72336 /Makefile
parent0411ca7aaef598a4d517376d34fdeb7f5ddfdc7d (diff)
downloadasync-70ae2fbc151baa88a9cec1f6ad0939ec584e7192.tar.gz
Build distribution file to lib/async.min.js
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 2bd1064..c3cec30 100644
--- a/Makefile
+++ b/Makefile
@@ -5,7 +5,7 @@ UGLIFY = "$(CWD)/node_modules/.bin/uglifyjs"
JSHINT = "$(CWD)/node_modules/.bin/jshint"
XYZ = node_modules/.bin/xyz --repo git@github.com:caolan/async.git
-BUILDDIR = dist
+BUILDDIR = lib
all: clean test build
@@ -28,6 +28,6 @@ lint:
.PHONY: release-major release-minor release-patch
release-major release-minor release-patch: all
./support/sync-package-managers.js
- git add --force dist
+ git add --force $(BUILDDIR)
git ci -am "update minified build"
@$(XYZ) --increment $(@:release-%=%)