summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorwchang0222%aol.com <devnull@localhost>2003-12-15 19:58:56 +0000
committerwchang0222%aol.com <devnull@localhost>2003-12-15 19:58:56 +0000
commiteffa1968d4cc4044df96a0c7d5d6d32a69e6e3a9 (patch)
treed2209f9f841ebe1c2a8539558f86598edd3a8a07 /configure.in
parentc957522a6ab4a508c433017e1046b348c7bb56d8 (diff)
downloadnspr-hg-effa1968d4cc4044df96a0c7d5d6d32a69e6e3a9.tar.gz
Bugzilla bug 226470: use a C compiler rather than a C++ compiler to compile
C code. Removed -qarch=com, which is the default for the compiler now. This patch is contributed by Philip K. Warren <pkw@us.ibm.com>. a=mkaply for Mozilla 1.6. Tag: NSPRPUB_PRE_4_2_CLIENT_BRANCH
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 2 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index d9a17a2c..3a95fb3b 100644
--- a/configure.in
+++ b/configure.in
@@ -252,9 +252,9 @@ if test -z "$CC"; then
*-aix*)
if test -z "$USE_NSPR_THREADS"; then
- CC=xlC_r
+ CC=xlc_r
else
- CC=xlC
+ CC=xlc
fi
;;
@@ -741,9 +741,6 @@ case "$target" in
;;
esac
CFLAGS="$CFLAGS -qro -qroconst"
- if echo "$CC" | grep -c xlC_r; then
- CFLAGS="$CFLAGS -qarch=com"
- fi
AIX_WRAP='$(DIST)/lib/aixwrap.o'
AIX_TMP='./_aix_tmp.o'
if test -n "$USE_64"; then