summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f635cc14..bfe776fe 100644
--- a/configure.in
+++ b/configure.in
@@ -870,6 +870,12 @@ case "$target" in
MDCPUCFG_H=_darwin.cfg
PR_MD_CSRCS=darwin.c
+ # Add Mac OS X support for loading CFM & CFBundle plugins
+ if test -f /System/Library/Frameworks/Carbon.framework/Carbon; then
+ AC_DEFINE(XP_MACOSX)
+ OS_TARGET=MacOSX
+ fi
+
dnl The C preprocessor can only handle integers in comparisons, so
dnl convert the version to the form AABBCC where AA=major release,
dnl BB=minor release, and CC=point/micro release.