summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py56
1 files changed, 30 insertions, 26 deletions
diff --git a/setup.py b/setup.py
index 515f849..2683fd9 100644
--- a/setup.py
+++ b/setup.py
@@ -5,13 +5,13 @@ from setuptools import setup
# Adapted from MNE-Python (BSD)
version = None
-with open(os.path.join('numpydoc', '_version.py')) as fid:
+with open(os.path.join("numpydoc", "_version.py")) as fid:
for line in (line.strip() for line in fid):
- if line.startswith('__version__'):
- version = line.split('=')[1].strip().strip('\'')
+ if line.startswith("__version__"):
+ version = line.split("=")[1].strip().strip("'")
break
if version is None:
- raise RuntimeError('Could not determine version')
+ raise RuntimeError("Could not determine version")
if sys.version_info < (3, 7):
raise RuntimeError("Python version >= 3.7 required.")
@@ -33,37 +33,41 @@ setup(
packages=["numpydoc"],
version=version,
description="Sphinx extension to support docstrings in Numpy format",
- long_description=read('README.rst'),
+ long_description=read("README.rst"),
# classifiers from http://pypi.python.org/pypi?%3Aaction=list_classifiers
- classifiers=["Development Status :: 4 - Beta",
- "Environment :: Plugins",
- "License :: OSI Approved :: BSD License",
- "Topic :: Documentation",
- "Programming Language :: Python",
- "Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.7",
- "Programming Language :: Python :: 3.8",
- "Programming Language :: Python :: 3.9",
- "Programming Language :: Python :: 3.10",
- ],
+ classifiers=[
+ "Development Status :: 4 - Beta",
+ "Environment :: Plugins",
+ "License :: OSI Approved :: BSD License",
+ "Topic :: Documentation",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
+ ],
keywords="sphinx numpy",
author="Pauli Virtanen and others",
author_email="pav@iki.fi",
url="https://numpydoc.readthedocs.io",
license="BSD",
- install_requires=["sphinx>=3.0", 'Jinja2>=2.10'],
+ install_requires=["sphinx>=3.0", "Jinja2>=2.10"],
python_requires=">=3.7",
extras_require={
"testing": [
- req for req in read('requirements/test.txt').split('\n')
- if not req.startswith('#')
+ req
+ for req in read("requirements/test.txt").split("\n")
+ if not req.startswith("#")
],
},
- package_data={'numpydoc': [
- 'tests/test_*.py',
- 'tests/tinybuild/Makefile',
- 'tests/tinybuild/index.rst',
- 'tests/tinybuild/*.py',
- 'templates/*.rst',
- ]},
+ package_data={
+ "numpydoc": [
+ "tests/test_*.py",
+ "tests/tinybuild/Makefile",
+ "tests/tinybuild/index.rst",
+ "tests/tinybuild/*.py",
+ "templates/*.rst",
+ ]
+ },
)