summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAllen Martin <amartin@nvidia.com>2012-11-19 16:14:05 -0800
committerAllen Martin <amartin@nvidia.com>2012-11-29 23:27:43 -0800
commitaa829095195bba27c935bcf3b83a53a5d920f757 (patch)
treeb155b42a571eff0480e501c955a6af42d30d1528 /src/Makefile.am
parent44ecb33b46f3b2bf39fdda8923111975cce6ab62 (diff)
downloadtegrarcm-aa829095195bba27c935bcf3b83a53a5d920f757.tar.gz
Add t114 support
Add support for t114. This includes a new T114 miniloader, new USB and nv3p device ids, and increased UID size. Signed-off-by: Allen Martin <amartin@nvidia.com> Change-Id: I5b77549317cad73c4499fe7797a30f09fffaebfb Reviewed-on: http://git-master/r/164851 Reviewed-by: Automatic_Commit_Validation_User Reviewed-by: Stephen Warren <swarren@nvidia.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 108ea01..4a6b71a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,5 +2,21 @@ AM_CFLAGS = -Wall -std=c99
AM_CPPFLAGS = -isystem /usr/include/$(CRYPTOLIB) $(LIBUSB_CFLAGS)
bin_PROGRAMS = tegrarcm
-tegrarcm_SOURCES = main.c usb.c nv3p.c debug.c rcm.c aes-cmac.cpp aes-cmac.h debug.h nv3p.h nv3p_status.h rcm.h tegra20-miniloader.h tegra30-miniloader.h usb.h
+tegrarcm_SOURCES = \
+ main.c \
+ usb.c \
+ nv3p.c \
+ debug.c \
+ rcm.c \
+ aes-cmac.cpp \
+ aes-cmac.h \
+ debug.h \
+ nv3p.h \
+ nv3p_status.h \
+ rcm.h \
+ tegra20-miniloader.h \
+ tegra30-miniloader.h \
+ tegra114-miniloader.h \
+ usb.h
+
tegrarcm_LDADD = $(LIBUSB_LIBS) -l$(CRYPTOLIB) -lpthread