summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohan Hedberg <johan.hedberg@intel.com>2011-07-04 15:25:55 +0300
committerJohan Hedberg <johan.hedberg@intel.com>2011-07-16 17:50:45 +0300
commit2cfb28e38daa9d3838a0b3a0328a7dc8a11f517e (patch)
tree924ebc3b492bb86949ae4d6a64e100a49304334c /Makefile.am
parent133f08d7ada0ef9feec2e177e11bf9e012c85171 (diff)
downloadobexd-2cfb28e38daa9d3838a0b3a0328a7dc8a11f517e.tar.gz
gobex: Add readline support to test-client
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e4dd300..c06b99c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -184,10 +184,12 @@ unit_test_gobex_header_SOURCES = $(gobex_sources) unit/test-gobex-header.c \
unit/util.c unit/util.h
unit_test_gobex_header_LDADD = @GLIB_LIBS@
+if READLINE
noinst_PROGRAMS += tools/test-client
tools_test_client_SOURCES = $(gobex_sources) $(btio_sources) \
tools/test-client.c
-tools_test_client_LDADD = @GLIB_LIBS@ @BLUEZ_LIBS@
+tools_test_client_LDADD = @GLIB_LIBS@ @BLUEZ_LIBS@ @READLINE_LIBS@
+endif
noinst_PROGRAMS += tools/test-server
tools_test_server_SOURCES = $(gobex_sources) $(btio_sources) \