summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLuiz Augusto von Dentz <luiz.dentz-von@nokia.com>2010-12-09 15:41:38 +0200
committerJohan Hedberg <johan.hedberg@nokia.com>2010-12-09 16:01:07 +0200
commit3a4a93198586f1efe4714fb1391f24c92f6057d6 (patch)
tree89d6ecd077bb993f6ad556351f37a0fc0a099c07 /Makefile.am
parenta6d422a14d27bd1510e111cddc81ff85a607a20f (diff)
downloadobexd-3a4a93198586f1efe4714fb1391f24c92f6057d6.tar.gz
Fix compiler flags when CFLAGS is set in the environment
D_FILE_OFFSET_BITS need to be set even if CFLAGS is not empty
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 175747c..a317556 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -123,7 +123,7 @@ service_DATA = $(service_in_files:.service.in=.service)
AM_CFLAGS = @OPENOBEX_CFLAGS@ @BLUEZ_CFLAGS@ @EBOOK_CFLAGS@ \
@GTHREAD_CFLAGS@ @GLIB_CFLAGS@ @DBUS_CFLAGS@ \
- @LIBICAL_CFLAGS@ \
+ @LIBICAL_CFLAGS@ -D_FILE_OFFSET_BITS=64 \
-DOBEX_PLUGIN_BUILTIN -DPLUGINDIR=\""$(plugindir)"\"
INCLUDES = -I$(builddir)/src -I$(srcdir)/src -I$(srcdir)/plugins \