summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohan Hedberg <johan.hedberg@intel.com>2011-07-06 11:05:02 +0300
committerJohan Hedberg <johan.hedberg@intel.com>2011-07-16 17:50:50 +0300
commit72095d25e2a096913128072c2739193f559e6d2c (patch)
tree7c973990a38ed08479571f33ec99fc67d11ca758 /Makefile.am
parent5b7755a622987f1b5e9616a6c82c77551724707c (diff)
downloadobexd-72095d25e2a096913128072c2739193f559e6d2c.tar.gz
gobex: Add unit test for put transfer API
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index afe17f9..57a72a2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -168,10 +168,11 @@ plugins/phonebook.c: plugins/@PHONEBOOK_DRIVER@
plugins/messages.c: plugins/@MESSAGES_DRIVER@
$(AM_V_GEN)$(LN_S) @abs_top_srcdir@/$< $@
-TESTS = unit/test-gobex-header unit/test-gobex-packet unit/test-gobex
+TESTS = unit/test-gobex-header unit/test-gobex-packet unit/test-gobex \
+ unit/test-gobex-transfer
noinst_PROGRAMS += unit/test-gobex-header unit/test-gobex-packet \
- unit/test-gobex
+ unit/test-gobex unit/test-gobex-transfer
unit_test_gobex_SOURCES = $(gobex_sources) unit/test-gobex.c \
unit/util.c unit/util.h
@@ -185,6 +186,10 @@ unit_test_gobex_header_SOURCES = $(gobex_sources) unit/test-gobex-header.c \
unit/util.c unit/util.h
unit_test_gobex_header_LDADD = @GLIB_LIBS@
+unit_test_gobex_transfer_SOURCES = $(gobex_sources) unit/util.c unit/util.h \
+ unit/test-gobex-transfer.c
+unit_test_gobex_transfer_LDADD = @GLIB_LIBS@
+
if READLINE
noinst_PROGRAMS += tools/test-client
tools_test_client_SOURCES = $(gobex_sources) $(btio_sources) \