summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2011-08-12 11:45:09 +0300
committerJohan Hedberg <johan.hedberg@intel.com>2011-08-12 15:23:10 +0300
commiteeb8ba229db86457906b2551c2608dac1f54cf54 (patch)
tree2a34c0cb681fe409af440861b1c1791f39eb1f3a /Makefile.am
parentd276cd4bd0924b89a50666be3a65edca4b7220b8 (diff)
downloadobexd-eeb8ba229db86457906b2551c2608dac1f54cf54.tar.gz
client: add target driver support
This simplify target matching to a single place making it easier to add new targets/profiles. Matching is done by either friendly name e.g. opp, ftp... or Bluetooth UUID. Drivers are probed when a session is established and removed when the session is destroyed.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index d412f02..314afc4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -131,8 +131,8 @@ client_obex_client_SOURCES = $(gdbus_sources) $(gobex_sources) \
client/sync.h client/sync.c \
client/ftp.h client/ftp.c \
client/transfer.h client/transfer.c \
- client/agent.h client/agent.c
-
+ client/agent.h client/agent.c \
+ client/driver.h client/driver.c
client_obex_client_LDADD = @GLIB_LIBS@ @DBUS_LIBS@ @OPENOBEX_LIBS@ @BLUEZ_LIBS@
endif