summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJohan Hedberg <johan.hedberg@intel.com>2011-05-18 12:12:13 -0700
committerJohan Hedberg <johan.hedberg@intel.com>2011-05-18 12:17:52 -0700
commit6134dcbbb5acfa1b567aebb798597e9f96cf47ce (patch)
tree483d65edcf9a6bd0d092ea34616330fd24fee7ad /configure.ac
parentcd71851f1748a2d04809d620eebae2b5fe96466e (diff)
downloadobexd-6134dcbbb5acfa1b567aebb798597e9f96cf47ce.tar.gz
Add support for tracker-0.10
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 10 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index fb349ae..6ca54ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -149,10 +149,16 @@ if (test "${phonebook_driver}" = "ebook"); then
fi
if (test "${phonebook_driver}" = "tracker"); then
- PKG_CHECK_MODULES(TRACKER_SPARQL, tracker-sparql-0.9, dummy=yes,
- AC_MSG_ERROR(libtracker-sparql is required))
- AC_SUBST(TRACKER_SPARQL_CFLAGS)
- AC_SUBST(TRACKER_SPARQL_LIBS)
+ PKG_CHECK_MODULES(TRACKER_09, tracker-sparql-0.9, [
+ TRACKER_CFLAGS=${TRACKER_09_CFLAGS}
+ TRACKER_LIBS=${TRACKER_09_CFLAGS}
+ ], [
+ PKG_CHECK_MODULES(TRACKER_10, tracker-sparql-0.10, [
+ TRACKER_CFLAGS=${TRACKER_10_CFLAGS}
+ TRACKER_LIBS=${TRACKER_10_LIBS}
+ ], AC_MSG_ERROR(libtracker-sparql is required))])
+ AC_SUBST(TRACKER_CFLAGS)
+ AC_SUBST(TRACKER_LIBS)
fi
AC_SUBST([PHONEBOOK_DRIVER], [phonebook-${phonebook_driver}.c])