summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSébastien Hinderer <Sebastien.Hinderer@inria.fr>2022-09-11 13:56:18 +0200
committerSébastien Hinderer <Sebastien.Hinderer@inria.fr>2022-09-27 15:15:36 +0200
commit222a3b1d57479c461835c62b20b738b0c6ff8bd2 (patch)
treebc3b36984fb598bcd3ff34fccbced0c089e462e2 /configure.ac
parenta21a8e4d9b2194222b50839bf8e5bef7a56ff0d8 (diff)
downloadocaml-222a3b1d57479c461835c62b20b738b0c6ff8bd2.tar.gz
Introduce and use the lib_runtime_events boolean configuration variable
The configure script sets this variable to "true" if the runtime_events library has to be built. At the moment it is always built but this may change.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 029582a417..4190c47b37 100644
--- a/configure.ac
+++ b/configure.ac
@@ -160,6 +160,7 @@ AC_SUBST([instrumented_runtime_libs])
AC_SUBST([has_monotonic_clock])
AC_SUBST([otherlibraries])
AC_SUBST([lib_dynlink])
+AC_SUBST([lib_runtime_events])
AC_SUBST([lib_str])
AC_SUBST([lib_systhreads])
AC_SUBST([lib_unix])
@@ -619,6 +620,7 @@ AS_CASE([$host],
otherlibraries="dynlink runtime_events"
lib_dynlink=true
+lib_runtime_events=true
AS_IF([test x"$enable_unix_lib" != "xno"],
[enable_unix_lib=yes
AC_CONFIG_FILES([otherlibs/unix/META])