summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorXavier Leroy <xavierleroy@users.noreply.github.com>2020-06-01 19:10:12 +0200
committerGitHub <noreply@github.com>2020-06-01 19:10:12 +0200
commit4bf7a79137c9d9083354593c98ada4ba0a657bae (patch)
tree2eca30fc9f06ea7e22609f1c17ea79fb1494d1d9 /configure.ac
parent9114ab0545c025544c5ad7e0c362f8cf3620a0c3 (diff)
downloadocaml-4bf7a79137c9d9083354593c98ada4ba0a657bae.tar.gz
Turn debugger off in programs launched by the program being debugged (#9594)
* Undefine the CAML_DEBUG_SOCKET variable early So that if the debugged program creates or executes another program that happens to be an OCaml bytecode executable, said program does not try to connect to the debugger at beginning of execution. Fixes: #8678 * Check availability of setenv() and unsetenv() And guard the use of unsetenv() in runtime/debugger.c.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e756cb638b..0d8218cb96 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1429,6 +1429,11 @@ AS_CASE([$host],
AC_CHECK_FUNC([putenv], [AC_DEFINE([HAS_PUTENV])])
+## setenv and unsetenv
+
+AC_CHECK_FUNC([setenv],
+ [AC_CHECK_FUNC([unsetenv], [AC_DEFINE([HAS_SETENV_UNSETENV])])])
+
## newlocale() and <locale.h>
# Note: the detection fails on msvc so we hardcode the result
# (should be debugged later)