summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAntonin Décimo <antonin@tarides.com>2023-01-02 16:26:21 +0100
committerAntonin Décimo <antonin@tarides.com>2023-01-12 14:58:35 +0100
commit567cf9f6ffd2a954e5f773d05530c30aeb381f68 (patch)
treeb7e8487fea5dd06b81212829f465a3955bdff993 /configure.ac
parent102d9606965dc7e393114a35c4510a603c91528e (diff)
downloadocaml-567cf9f6ffd2a954e5f773d05530c30aeb381f68.tar.gz
Enable stricter C99 warnings
Fedora is considering moving all its packages to C99 and enabling stricter C99 warnings. OCaml has already moved to a compiler requiring C11 features, let's enable these warnings on GCC-compatible compilers. Some of the warnings on the following article are already covered by -Wall and -Werror. Reference: [Modernizing Fedora's C code][1]. [1]: https://lwn.net/Articles/913505/
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e7956cb6c8..cab28adb0b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -688,7 +688,8 @@ AS_CASE([$ocaml_cv_cc_vendor],
cc_warnings=''],
[outputobj='-o '
warn_error_flag='-Werror'
- cc_warnings='-Wall'])
+ cc_warnings="-Wall -Wint-conversion -Wstrict-prototypes \
+-Wold-style-definition"])
AS_CASE([$enable_warn_error,OCAML__DEVELOPMENT_VERSION],
[yes,*|,true],